summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-04-09 23:02:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-04-09 23:45:33 +0200
commitdaf11f7d9538086592cf7ef9a55ea0a7cb5e775f (patch)
treeaa7ef5b632c6b976078bb5723d8766893e371ab0 /kde-frameworks
parentapp-containers/crun: Add selinux-container policy dep (diff)
downloadgentoo-daf11f7d9538086592cf7ef9a55ea0a7cb5e775f.tar.gz
gentoo-daf11f7d9538086592cf7ef9a55ea0a7cb5e775f.tar.bz2
gentoo-daf11f7d9538086592cf7ef9a55ea0a7cb5e775f.zip
kde-frameworks/frameworkintegration: 5.93.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.93.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index fe51bdda2e00..82ca9bbe3644 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.90.0.tar.xz 1758208 BLAKE2B c8a7a11677ca77032be1ef1491ba5d8efa356caf6e7704b240a50baec7119b64ba85d4d183692164a1de58ee42c8d92686c9abe3d14af0bd8493ff747d9ddb7f SHA512 4f27d8aa453ab5d08e410db4c93bd86386159bb3e82a65cff0c4264ec3467f916a761e7cc0f68365c3f821cce8c84ff6277afb975a967fe26ed7a545155defca
DIST frameworkintegration-5.92.0.tar.xz 1758268 BLAKE2B 7f72908f93158f42c2e90488aa037bb7dd9146e333b504a9034c8b5c6898fb5a6357a62fc81c237f8be9b854d05c97ce4352d28aa4f28ba1674d26b0098c7e41 SHA512 3445749f4ee10493a798433a7b5630dc22701c98c3f81c7e2236cffea9f9576ce8123006e5123698e5d648771ea77bff848453b188b1a6e791aab08184cebecc
+DIST frameworkintegration-5.93.0.tar.xz 1758280 BLAKE2B 9bc1d3e711ea548a561b81850e50c0e920b87cbf4a47506e1f4a7beca067030eaff50c857c59493198e98cf91673bc3e531fc35bc5c935573c8ba9d0202cb480 SHA512 679cecf3852965d0f746a44ece7ac993328d8133745c9c7a9afc05855e9f3497964a558e08d69b6baf7ca700b01611a1dd6c13d4ef145a3cd92b9459f5f753c0
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.93.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.93.0.ebuild
new file mode 100644
index 000000000000..035cdd529c64
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.93.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}