summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-28 21:21:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-28 21:22:16 +0100
commit7a66df3ef78aab42f0e33427c35e5c865cda88c2 (patch)
treec8baf6df564df66acc8c9572e01caeb94bbcd6cc /kde-plasma/kwallet-pam/kwallet-pam-5.11.4.ebuild
parentwww-client/opera-beta: Old. (diff)
downloadgentoo-7a66df3ef78aab42f0e33427c35e5c865cda88c2.tar.gz
gentoo-7a66df3ef78aab42f0e33427c35e5c865cda88c2.tar.bz2
gentoo-7a66df3ef78aab42f0e33427c35e5c865cda88c2.zip
kde-plasma: Add KDE Plasma 5.11.4
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'kde-plasma/kwallet-pam/kwallet-pam-5.11.4.ebuild')
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.11.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.11.4.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.11.4.ebuild
new file mode 100644
index 000000000000..d591eb59e0fd
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.11.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ -DKWALLET4=0
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}