summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-21 20:13:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-21 21:05:17 +0200
commit9cfdd7e23523f884c7426868a3741566db0ac4dd (patch)
treeffb07badf46211e8f527aac17e1adf586fa829c0 /kde-plasma/plasma-integration
parentkde-plasma/plasma-firewall: 6.0.5 version bump (diff)
downloadgentoo-9cfdd7e23523f884c7426868a3741566db0ac4dd.tar.gz
gentoo-9cfdd7e23523f884c7426868a3741566db0ac4dd.tar.bz2
gentoo-9cfdd7e23523f884c7426868a3741566db0ac4dd.zip
kde-plasma/plasma-integration: 6.0.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-6.0.5.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 0efd849ea295..7e5b0b0d5b0e 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.27.11.tar.xz 89460 BLAKE2B b6e0f487332c7280d394c9e84c44f18cd0694812307fdb1109a27d7f04ac5e0b2c6934adfed10fcbb65b5ec358e4ece728c8761edbc2872f33b40d3cff54495f SHA512 34e040425a11089bdda444132c224af8b4fca5d3fd30e875d4a385ad26bb215409c076c19ee3a2bbe3736121a7988bbc6ca564814f4e28b8e20acb5ebc194347
DIST plasma-integration-6.0.4.tar.xz 92584 BLAKE2B 61545df5f849812e745be6098842e1a7847e231077b316df03d0d4f5dcec7de32d7bc0ab5e8d000145f089137a19d54df5a593cd3b4eeab8d802a452c83cc142 SHA512 80bd8d44ceb920109d971027f71eafbdc682972d7b0eb737504c840befd47ccd6dc1536e67e173d1df11b38bb91bd493351159de853fdd2b5035800846004833
+DIST plasma-integration-6.0.5.tar.xz 92464 BLAKE2B 7bf1ae70de4e0eeb9402eeeb37e2a29735b97476d673974e30f90d50ca06612d341184e811b1ff86c4d6f12b99e4b5c341f74b92f96264b5f16cc36927ead3f1 SHA512 54c1dd96610cfa479cf4edf2b937ef1543a42ec3edec29c515ed3db49093b7ea2e5ec425d70142e47e9bcf95c28747fb1e28cd0e5dba28ba4a7515a146c0ff0c
diff --git a/kde-plasma/plasma-integration/plasma-integration-6.0.5.ebuild b/kde-plasma/plasma-integration/plasma-integration-6.0.5.ebuild
new file mode 100644
index 000000000000..1f740140256d
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-6.0.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KF5MIN=5.115.0
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+QT5MIN=5.15.12
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="qt5"
+
+# requires running kde environment
+RESTRICT="test"
+
+# slot ops: qdbus*_p.h and Qt6::GuiPrivate for qtx11extras_p.h
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=kde-frameworks/kcolorscheme-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ x11-libs/libXcursor
+ x11-libs/libxcb
+ qt5? (
+ >=dev-qt/qtdbus-${QT5MIN}:5
+ >=dev-qt/qtgui-${QT5MIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QT5MIN}:5
+ >=dev-qt/qtwayland-${QT5MIN}:5
+ >=dev-qt/qtwidgets-${QT5MIN}:5
+ >=dev-qt/qtx11extras-${QT5MIN}:5
+ >=kde-frameworks/kcompletion-${KF5MIN}:5
+ >=kde-frameworks/kconfig-${KF5MIN}:5
+ >=kde-frameworks/kconfigwidgets-${KF5MIN}:5
+ >=kde-frameworks/kcoreaddons-${KF5MIN}:5
+ >=kde-frameworks/kguiaddons-${KF5MIN}:5
+ >=kde-frameworks/ki18n-${KF5MIN}:5
+ >=kde-frameworks/kiconthemes-${KF5MIN}:5
+ >=kde-frameworks/kio-${KF5MIN}:5
+ >=kde-frameworks/kjobwidgets-${KF5MIN}:5
+ >=kde-frameworks/knotifications-${KF5MIN}:5
+ >=kde-frameworks/kwindowsystem-${KF5MIN}:5
+ >=kde-frameworks/kxmlgui-${KF5MIN}:5
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.11.1
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+ media-fonts/noto-emoji
+"
+PDEPEND="
+ >=kde-plasma/xdg-desktop-portal-kde-${PVCUT}:6
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ qt5? ( >=dev-qt/qtwaylandscanner-${QT5MIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_QT6=ON
+ -DBUILD_QT5=$(usex qt5)
+ )
+ ecm_src_configure
+}