summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-16 21:50:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-17 00:38:07 +0200
commit6692de0e20892106db8051807d05ab6168bd17f3 (patch)
tree7ae5005c84587114c8f3e26eaf89dd609ed471b5 /kde-plasma
parentkde-plasma/plasma-workspace: Fix animation duration w/ KF-5.70 (diff)
downloadgentoo-6692de0e20892106db8051807d05ab6168bd17f3.tar.gz
gentoo-6692de0e20892106db8051807d05ab6168bd17f3.tar.bz2
gentoo-6692de0e20892106db8051807d05ab6168bd17f3.zip
kde-plasma/plasma-workspace: sddm-theme: Prevent logo from leaking in
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.18.5-sddm-theme-prevent-logo-leaking.patch94
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-5.18.5-r1.ebuild2
2 files changed, 96 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.18.5-sddm-theme-prevent-logo-leaking.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.18.5-sddm-theme-prevent-logo-leaking.patch
new file mode 100644
index 000000000000..7cbe139a1669
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.18.5-sddm-theme-prevent-logo-leaking.patch
@@ -0,0 +1,94 @@
+From 68601675d13bdf44248991a56e888093e58c56c3 Mon Sep 17 00:00:00 2001
+From: Filip Fila <filipfila.kde@gmail.com>
+Date: Wed, 13 May 2020 18:08:27 +0200
+Subject: [sddm-theme] Prevent the logo from leaking in after a fadeout
+
+Summary:
+Even when the vendor logo is turned off it can be briefly seen when the login screen changes from the fadeout state back into normal.
+
+Comments in other code say that "OpacityAnimator when starting from 0 is buggy (it shows one frame with opacity 1)" so this patch replaces it with NumberAnimation.
+
+There's also a minor fix included - placing the drop shadow sooner in the hierarchy because it should be drawn underneath an object, not in front of it.
+
+Test Plan:
+Reduce the fadeout time to something small and then:
+
+`sddm-greeter --test-mode --theme /usr/share/sddm/themes/breeze`
+
+Reviewers: ngraham, cblack, #plasma, mart
+
+Reviewed By: ngraham, #plasma, mart
+
+Subscribers: mart, plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D29351
+---
+ sddm-theme/Main.qml | 44 +++++++++++++++++++++++---------------------
+ 1 file changed, 23 insertions(+), 21 deletions(-)
+
+diff --git a/sddm-theme/Main.qml b/sddm-theme/Main.qml
+index 6746238..9910e7f 100644
+--- a/sddm-theme/Main.qml
++++ b/sddm-theme/Main.qml
+@@ -411,26 +411,6 @@ PlasmaCore.ColorScope {
+ }
+ }
+
+- Image {
+- id: logo
+- visible: config.showlogo == "shown"
+- source: config.logo
+- anchors.horizontalCenter: parent.horizontalCenter
+- anchors.bottom: footer.top
+- anchors.bottomMargin: units.largeSpacing
+- asynchronous: true
+- sourceSize.height: height
+- opacity: loginScreenRoot.uiVisible ? 0 : 1
+- fillMode: Image.PreserveAspectFit
+- height: Math.round(units.gridUnit * 3.5)
+- Behavior on opacity {
+- OpacityAnimator {
+- duration: units.longDuration
+- easing.type: Easing.InOutQuad
+- }
+- }
+- }
+-
+ DropShadow {
+ id: logoShadow
+ anchors.fill: logo
+@@ -444,7 +424,29 @@ PlasmaCore.ColorScope {
+ color: "black" // matches Breeze window decoration and desktopcontainment
+ opacity: loginScreenRoot.uiVisible ? 0 : 1
+ Behavior on opacity {
+- OpacityAnimator {
++ //OpacityAnimator when starting from 0 is buggy (it shows one frame with opacity 1)"
++ NumberAnimation {
++ duration: units.longDuration
++ easing.type: Easing.InOutQuad
++ }
++ }
++ }
++
++ Image {
++ id: logo
++ visible: config.showlogo == "shown"
++ source: config.logo
++ anchors.horizontalCenter: parent.horizontalCenter
++ anchors.bottom: footer.top
++ anchors.bottomMargin: units.largeSpacing
++ asynchronous: true
++ sourceSize.height: height
++ opacity: loginScreenRoot.uiVisible ? 0 : 1
++ fillMode: Image.PreserveAspectFit
++ height: Math.round(units.gridUnit * 3.5)
++ Behavior on opacity {
++ // OpacityAnimator when starting from 0 is buggy (it shows one frame with opacity 1)"
++ NumberAnimation {
+ duration: units.longDuration
+ easing.type: Easing.InOutQuad
+ }
+--
+cgit v1.1
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-5.18.5-r1.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-5.18.5-r1.ebuild
index 269e6a9c5646..4662a7858bf0 100644
--- a/kde-plasma/plasma-workspace/plasma-workspace-5.18.5-r1.ebuild
+++ b/kde-plasma/plasma-workspace/plasma-workspace-5.18.5-r1.ebuild
@@ -127,6 +127,8 @@ PDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-5.14.2-split-libkworkspace.patch" # downstream patch
+ "${FILESDIR}/${P}-sddm-theme-prevent-logo-leaking.patch" # in Plasma/5.18
+
# Fix animation duration w/ KDE Frameworks 5.70 (Plasma/5.19 backport):
# https://pointieststick.com/2020/05/10/why-the-animations-in-your-plasma-5-18-feel-slow-now-and-when-it-will-be-fixed/
"${FILESDIR}/${P}-stop-multiplying-duration-values.patch"