summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-04 10:15:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-04 16:19:29 +0100
commitabff4bbdb17b05045e5d031a9781877e23c622d3 (patch)
treec2fd83c70fbdcd53394d530f4e89a8b8795bf53e /kde-plasma
parentkde-plasma/kwallet-pam: 5.26.5 version bump (diff)
downloadgentoo-abff4bbdb17b05045e5d031a9781877e23c622d3.tar.gz
gentoo-abff4bbdb17b05045e5d031a9781877e23c622d3.tar.bz2
gentoo-abff4bbdb17b05045e5d031a9781877e23c622d3.zip
kde-plasma/kwayland-integration: 5.26.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.26.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 2aca4f113852..56670e74a987 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.25.5.tar.xz 24296 BLAKE2B 30fd0d0c2cb8ce34da692a40d558e7616796475f74ff7fc4212fdded88e7c55271836f160b48907fd3e195f41738c294e40c122bf51ec967861e17bc3d7de3bd SHA512 eabb2040275fd32b4ca1e8a5717a05589a331aac97e21861f36e8ac2b3c683b369d5f40507b0dbebd714dc766d311bd1233043327253e3c5d68de2464e12a342
DIST kwayland-integration-5.26.4.tar.xz 26976 BLAKE2B 8d4afb514c6851255f437360a8240d95d9d2c5d51c3ada30bf1a8c30bda1a063e89e098509bc69e8226d7bfb18185221b909081982eab1d8ed2b80c9c84cce47 SHA512 59cf5dcdc8713654221ac5411885be5b656bf1d1cefd344f35b1a3f45e2f036a43633eb474bcc4357783e4e5114afee6c192c63e4c02325d8db9b329b460f1e3
+DIST kwayland-integration-5.26.5.tar.xz 26972 BLAKE2B 108eeebc92768755fba22d7435829f514904a3f39c748a70f220c1ae4fa078d5def0921f6c96effc2c7cc1ae0580d8c251034e87acaf4107d340b7bfdac1e443 SHA512 de252e67f488f920538a15e69836d4b8779a3123e1913c78cb7d69833a8fa475eb1166928cc965bc7ad69aa26d3dc58395ac7d06fb2349120bd014939d81e229
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.26.5.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.26.5.ebuild
new file mode 100644
index 000000000000..ea256a3b9309
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.26.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}