summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-24 23:13:31 +0100
committerSam James <sam@gentoo.org>2023-10-24 23:35:56 +0100
commitbf6f5402203f781468c55f7f7bf6072d965d8bce (patch)
treecbc54682ce520568d4d7bd02242b466bb72eaa18 /kde-plasma
parentkde-plasma/oxygen-sounds: 5.27.9 version bump (diff)
downloadgentoo-bf6f5402203f781468c55f7f7bf6072d965d8bce.tar.gz
gentoo-bf6f5402203f781468c55f7f7bf6072d965d8bce.tar.bz2
gentoo-bf6f5402203f781468c55f7f7bf6072d965d8bce.zip
kde-plasma/plasma-browser-integration: 5.27.9 version bump
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-browser-integration/Manifest1
-rw-r--r--kde-plasma/plasma-browser-integration/plasma-browser-integration-5.27.9.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/plasma-browser-integration/Manifest b/kde-plasma/plasma-browser-integration/Manifest
index 5f33d3c858a0..741ca82eaf55 100644
--- a/kde-plasma/plasma-browser-integration/Manifest
+++ b/kde-plasma/plasma-browser-integration/Manifest
@@ -1 +1,2 @@
DIST plasma-browser-integration-5.27.8.tar.xz 211188 BLAKE2B 76f0884aac7d76a21edffae4547d00b2d39ce2828eed143a07ffbd0b19036acdf1cbaf15b63c262764b5950d98e95bc2aa1739755d9b55c883e63cf805cfb4a5 SHA512 6f14eda9d4bfa03ed6851f71b410614559af0d0b25d0842bf8888a70d407573608b860d5c47830ce20340a0c2b234b45e43f0649fe9a9108aff1ce39cc8ce404
+DIST plasma-browser-integration-5.27.9.tar.xz 211156 BLAKE2B 41db564b30fb728c93d4fb4bac1ed8dcab03786038f82f03024eda6084ffb84f2b5241eea2f0e9c9a64fe1646ba021431b0d38bd28c68478010928ae85135fe4 SHA512 6653057b1ba79b50f64ef709e8da573a5e44f5da0669e7771155162ff53e7ba43b64320731d18bb491be87c7230589a923d2c1ddcfd56f6a6601293a1b57fb0d
diff --git a/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.27.9.ebuild b/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.27.9.ebuild
new file mode 100644
index 000000000000..d7200be9f073
--- /dev/null
+++ b/kde-plasma/plasma-browser-integration/plasma-browser-integration-5.27.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Integrate Chrome/Firefox better into Plasma through browser extensions"
+HOMEPAGE+=" https://community.kde.org/Plasma/Browser_Integration"
+
+LICENSE="GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kfilemetadata-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/purpose-${KFMIN}:5
+ >=kde-plasma/plasma-workspace-${PVCUT}:5
+"
+DEPEND="${RDEPEND}
+ >=kde-frameworks/krunner-${KFMIN}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMOZILLA_DIR="${EPREFIX}/usr/$(get_libdir)/mozilla"
+ )
+
+ ecm_src_configure
+}