summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-24 23:11:30 +0100
committerSam James <sam@gentoo.org>2023-10-24 23:35:46 +0100
commitc3fa5e8675cefad8efe6b6063a3d9c662383fdae (patch)
tree4be501bd5e8d2ddf7c8c0b2bfa8ea71859599b62 /kde-plasma
parentkde-plasma/khotkeys: 5.27.9 version bump (diff)
downloadgentoo-c3fa5e8675cefad8efe6b6063a3d9c662383fdae.tar.gz
gentoo-c3fa5e8675cefad8efe6b6063a3d9c662383fdae.tar.bz2
gentoo-c3fa5e8675cefad8efe6b6063a3d9c662383fdae.zip
kde-plasma/kinfocenter: 5.27.9 version bump
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.27.9.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index d083b23017f0..c2a89a2c3c9d 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,2 +1,3 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.27.8.tar.xz 1016252 BLAKE2B 8987049c2d2edc890e52be98749d740158616cd928462fc3e14936d1b5223ac906904e9b41596df1048b69693aaa8bac85b768c3c5f2bb25f70c03712d1e6705 SHA512 195973588998a91e87134e795c46706af89e8fa10207571ba8d949fb5398ff969d48a8d75a2b77dd17333e29b0ca01bd907ed9a9f2a98a16fa9c5afa00c0c2d1
+DIST kinfocenter-5.27.9.tar.xz 1016368 BLAKE2B 14281837c83947ef1f75b686efdcbb34243c4cab21d5de2198fdc87252b3fb0d20a3052ebf772e12b53960d7e9cd9cbf7c18abe8d943d3ede058b518f5884047 SHA512 9ba52890b4924989e68a7cdff2841ebd2adceac6b7412fecaaae31b98ba997ab7bf9a6e7917412b19e9787329bc16a1973bbff546816ffe3f2037e4840de7c19
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.27.9.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.27.9.ebuild
new file mode 100644
index 000000000000..f50544db4566
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.27.9.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.106.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.9
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qdbus:*
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+ >=kde-plasma/systemsettings-${PVCUT}:5
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}