summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-14 10:23:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-14 14:43:05 +0200
commitcf2e87940e88aadfa9334a2a0c1f1213ed8a606d (patch)
tree2348f033853b7120b2ff8be20f9630f47e03a245 /kde-plasma
parentkde-plasma/kscreenlocker: 5.25.0 version bump (diff)
downloadgentoo-cf2e87940e88aadfa9334a2a0c1f1213ed8a606d.tar.gz
gentoo-cf2e87940e88aadfa9334a2a0c1f1213ed8a606d.tar.bz2
gentoo-cf2e87940e88aadfa9334a2a0c1f1213ed8a606d.zip
kde-plasma/ksshaskpass: 5.25.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.25.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index b58041fd1e2e..804a5a889b87 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1 +1,2 @@
DIST ksshaskpass-5.24.5.tar.xz 24708 BLAKE2B e6937ec76b6cadff437c77eaceb075d7050e6d3581e64b66c1a07491352e335e63dc58b6655da6f5532919295bfad0e13da6855370b4c0a3c1eacb9698dc1759 SHA512 e4d7358eb213105a4e479eb3c9d229a87d86c4ebda199f486f9952f81dc1e91b43ba30d834907586f9badbb7e2933e44af5713119caa2e3bc060f16936e9a457
+DIST ksshaskpass-5.25.0.tar.xz 24884 BLAKE2B 1904644eed923daad440e3b9cb254d74b9dda42fb0783947d902686c343dd6c2bf5b9caeb1ff1b528b6f0f99ffd70332dcb7a3d9a12721e1b62b266a685720cc SHA512 1f2666a14ae252e9943a3a97bf642145598378cd0a9db4c3008e466a4f937a742a7cdeec5757c0fcebda7a9bcf23f0924f900eba5286d2bd321f4148db906f4e
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.25.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.25.0.ebuild
new file mode 100644
index 000000000000..ca8f351f499a
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.25.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.94.0
+QTMIN=5.15.3
+inherit ecm kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}