summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxqt-base/libsysstat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxqt-base/libsysstat')
-rw-r--r--lxqt-base/libsysstat/Manifest3
-rw-r--r--lxqt-base/libsysstat/libsysstat-0.1.0.ebuild24
-rw-r--r--lxqt-base/libsysstat/libsysstat-0.2.0.ebuild34
-rw-r--r--lxqt-base/libsysstat/libsysstat-0.3.0.ebuild26
-rw-r--r--lxqt-base/libsysstat/metadata.xml9
5 files changed, 96 insertions, 0 deletions
diff --git a/lxqt-base/libsysstat/Manifest b/lxqt-base/libsysstat/Manifest
new file mode 100644
index 000000000000..4ca361f6c55c
--- /dev/null
+++ b/lxqt-base/libsysstat/Manifest
@@ -0,0 +1,3 @@
+DIST libsysstat-0.1.0.tar.xz 16376 SHA256 beafdb971fbe282d7698fb2230024382bc7f100d9af13f2a4bafc97509089d9f SHA512 d5454055a631aa3c66be8f4b24d2eec0b5d86941ccfa80efc3f831558e5fbd06681060a641aad8968590e61274478f6fad80a518150e9461d8dbd9a48faca497 WHIRLPOOL 556201bd21fa2d24e8d1d874657b27352acd13d15552a5083e3dfa4adef6fb5ef2a34d365ce5ac2a82834eaaac941a70c73cfd3ace6f7589796a659a80b4e0f2
+DIST libsysstat-0.2.0.tar.xz 17156 SHA256 f517c89f8e2abdc90f3f602db6cba89d8405a3d86782f77f663d784d0ecc70ad SHA512 fa01a80e11744b3d3c15916162053c0f79c9c57425d9054b14588e710df67d44d2bb73b7d64a8ae438debf2b0b348546840f8325843d21d6c146cf6d7dab0b97 WHIRLPOOL 0d2fb8abe0ba32be2dbb94417e92b2415fc45df45af98b9d8e12201b089e137fafb135ab5aaffb927024acfe780886d576f9235bae11f5e28b248b4c41144e60
+DIST libsysstat-0.3.0.tar.xz 17008 SHA256 ab6405ac1c2e547ab07c03556b356a462caf40bfb8c885f3ff6b6df82f012718 SHA512 41bbc270b5968459a40ce511fb93c9aae8b0d85d603299abc925c52fd38c11f3786d54abea7a8457c9fa869b519cdf47ac445cdff5f275339c6a960fb0e65c38 WHIRLPOOL e55bb621cb01b916f34808a96294114cece23cedd9208bcbb7a7d85fd052348798570921404068626cfab558c233aef18db30e8ed46fa6325374c72a1bef2e01
diff --git a/lxqt-base/libsysstat/libsysstat-0.1.0.ebuild b/lxqt-base/libsysstat/libsysstat-0.1.0.ebuild
new file mode 100644
index 000000000000..528445e42f29
--- /dev/null
+++ b/lxqt-base/libsysstat/libsysstat-0.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A Qt-based interface to system statistics"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="dev-qt/qtcore:4"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/libsysstat/libsysstat-0.2.0.ebuild b/lxqt-base/libsysstat/libsysstat-0.2.0.ebuild
new file mode 100644
index 000000000000..f0547835e192
--- /dev/null
+++ b/lxqt-base/libsysstat/libsysstat-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A Qt-based interface to system statistics"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/lxqt-base/libsysstat/libsysstat-0.3.0.ebuild b/lxqt-base/libsysstat/libsysstat-0.3.0.ebuild
new file mode 100644
index 000000000000..93dd8741231a
--- /dev/null
+++ b/lxqt-base/libsysstat/libsysstat-0.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A Qt-based interface to system statistics"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+"
+RDEPEND="${DEPEND}"
diff --git a/lxqt-base/libsysstat/metadata.xml b/lxqt-base/libsysstat/metadata.xml
new file mode 100644
index 000000000000..d89dead0ed86
--- /dev/null
+++ b/lxqt-base/libsysstat/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>