summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /lxqt-base/lxqt-powermanagement
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'lxqt-base/lxqt-powermanagement')
-rw-r--r--lxqt-base/lxqt-powermanagement/Manifest3
-rw-r--r--lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.7.0.ebuild34
-rw-r--r--lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.8.0.ebuild45
-rw-r--r--lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.9.0.ebuild38
-rw-r--r--lxqt-base/lxqt-powermanagement/metadata.xml9
5 files changed, 129 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-powermanagement/Manifest b/lxqt-base/lxqt-powermanagement/Manifest
new file mode 100644
index 000000000000..f8323d9cd0bc
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/Manifest
@@ -0,0 +1,3 @@
+DIST lxqt-powermanagement-0.7.0.tar.xz 29336 SHA256 7f0456b9bcf416adb1e1c5c797a688bcd276680f0821e165b346364cd2926f87 SHA512 973332d331d3a8b794d06523e623650a38b019f03c40bff8519036c314c9835101e51fafe34a76e755c5e7e85d963e481d4b3562e4d2f4a08fab4c3f60b7fbde WHIRLPOOL 6156238d287ead2a83743552bdd030f5a60b30cd0dc2d19f183b878fb9e31fbdb77b101d14c4e0d9e37d2a95f5958b22e21a1376fe2d8345c9f9fe1ae032901e
+DIST lxqt-powermanagement-0.8.0.tar.xz 30236 SHA256 eb2605326c0598331e0c84624e319ef574c6dffc73d0bbc21782cb61a468d40c SHA512 56f3ab95fdf525a51072b5ad09d79df4e290ddb491dadd860a15abf383a5507456f9017ad06808001b99e2c11e2b9ad639ab22a3d48d44c86f1c21b90eb9f944 WHIRLPOOL 49b0d3bc3fcac1f7baccba8dfc8e774784fee8c5ee3958e4ae9c750e646eb22b5b28f50ec298225e2ac0125eec6d0b5d076134e8cfacf95bd61d95207d7f5562
+DIST lxqt-powermanagement-0.9.0.tar.xz 36292 SHA256 4602de9a9976307a74568cc729c6970c73dc06be5f972ade21eea6afb0c3006b SHA512 febd0f26f31a7295f5263d416926e75e28f6cca674a9511f3f9a9445290693cc43b092135776adaf234b851ae768877b11ee4b349d455f10d0917fcd046e3c7a WHIRLPOOL 465bb57876da10d6dd5050ddc579f241e54dba83ec89670e521be9cf842b7bf6b9d40c39b3c3423544cb124910765da2b01f879a82e82cc1d1910fddda5d905e
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.7.0.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.7.0.ebuild
new file mode 100644
index 000000000000..b5ae0ae4ed9c
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt daemon for power management and auto-suspend"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+CDEPEND="dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ ~lxqt-base/liblxqt-${PV}
+ ~dev-libs/libqtxdg-0.5.3
+ x11-libs/libX11
+ x11-libs/libxcb"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ || ( sys-power/upower sys-power/upower-pm-utils )"
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.8.0.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.8.0.ebuild
new file mode 100644
index 000000000000..e84c0fc6a890
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt daemon for power management and auto-suspend"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+CDEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ x11-libs/libX11
+ x11-libs/libxcb:="
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ || ( sys-power/upower sys-power/upower-pm-utils )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.9.0.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.9.0.ebuild
new file mode 100644
index 000000000000..8bb1e58ba127
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt daemon for power management and auto-suspend"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+CDEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ x11-libs/libX11
+ x11-libs/libxcb:="
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ || ( sys-power/upower sys-power/upower-pm-utils )"
diff --git a/lxqt-base/lxqt-powermanagement/metadata.xml b/lxqt-base/lxqt-powermanagement/metadata.xml
new file mode 100644
index 000000000000..d89dead0ed86
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxqt</herd>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>