summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-03-06 10:07:47 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-03-06 10:10:33 -0600
commit721c5b6eb1f07871c4d00f5f30bcf2590c5b5906 (patch)
tree262c4fc23b63e453fdd4a98c077c8483c3f756d8 /mail-client
parentdev-lang/python: Backport expat test fixes to 2.7 (diff)
downloadgentoo-721c5b6eb1f07871c4d00f5f30bcf2590c5b5906.tar.gz
gentoo-721c5b6eb1f07871c4d00f5f30bcf2590c5b5906.tar.bz2
gentoo-721c5b6eb1f07871c4d00f5f30bcf2590c5b5906.zip
mail-client/aerc: sync live
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/aerc/aerc-9999.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/mail-client/aerc/aerc-9999.ebuild b/mail-client/aerc/aerc-9999.ebuild
index fd14227f806c..44c0b5357581 100644
--- a/mail-client/aerc/aerc-9999.ebuild
+++ b/mail-client/aerc/aerc-9999.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-
-inherit go-module
+inherit go-module xdg
DESCRIPTION="Email client for your terminal"
HOMEPAGE="https://aerc-mail.org"
@@ -12,12 +11,8 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.sr.ht/~rjarry/aerc"
else
- EGO_SUM=(
- # to be filled on bumps
- )
- go-module_set_globals
- SRC_URI="https://git.sr.ht/~sircmpwn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- ${EGO_SUM_SRC_URI}"
+ SRC_URI="https://git.sr.ht/~rjarry/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.gz"
KEYWORDS="~amd64 ~ppc64"
fi
@@ -25,14 +20,13 @@ LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
IUSE="notmuch"
+DEPEND="notmuch? ( net-mail/notmuch:= )"
+RDEPEND="${DEPEND}"
BDEPEND="
>=app-text/scdoc-1.9.7
>=dev-lang/go-1.13
"
-DEPEND="notmuch? ( net-mail/notmuch:= )"
-RDEPEND="${DEPEND}"
-
src_unpack() {
if [[ ${PV} == *9999 ]]; then
git-r3_src_unpack
@@ -43,8 +37,9 @@ src_unpack() {
}
src_compile() {
- use notmuch && export GOFLAGS="-tags=notmuch"
- emake PREFIX="${EPREFIX}/usr" all
+ LDFLAGS= \
+ emake GOFLAGS="-mod=vendor $(usex notmuch "-tags=notmuch" "")" \
+ PREFIX="${EPREFIX}/usr"VERSION=${PV} all
}
src_install() {
@@ -68,4 +63,5 @@ pkg_postinst() {
elog "need to use them."
fi
done
+ xdg_pkg_postinst
}