summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-02-27 20:22:01 -0500
committerMatt Turner <mattst88@gentoo.org>2023-02-27 20:36:24 -0500
commit3ede7d876e7f4fe352101766abdea83540ab91a7 (patch)
treef5a315e5b827b3dbfacba2f31e573916ead497fb /media-fonts
parentmedia-fonts/font-misc-cyrillic: Version bump to 1.0.4 (diff)
downloadgentoo-3ede7d876e7f4fe352101766abdea83540ab91a7.tar.gz
gentoo-3ede7d876e7f4fe352101766abdea83540ab91a7.tar.bz2
gentoo-3ede7d876e7f4fe352101766abdea83540ab91a7.zip
media-fonts/font-misc-ethiopic: Version bump to 1.0.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/font-misc-ethiopic/Manifest1
-rw-r--r--media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/media-fonts/font-misc-ethiopic/Manifest b/media-fonts/font-misc-ethiopic/Manifest
index 58a204e032ce..bcc4cb8cd0dc 100644
--- a/media-fonts/font-misc-ethiopic/Manifest
+++ b/media-fonts/font-misc-ethiopic/Manifest
@@ -1 +1,2 @@
DIST font-misc-ethiopic-1.0.4.tar.bz2 270076 BLAKE2B b27d188fcb5be3e4e5fed810f26c0f5edf5a51a3532bd51b44e55283518bc1a353054da4f37c5535197eeb6958bfe1567ab54d1d9f428b046b84c5d1233aae21 SHA512 4fed9ff3782746898c56dac199e9ca89356f4967779937049b9ff4ffad202317c023859f92d44b371dfa5485d5368ccad648e64b12cde0ed21f7d4aee5affcd5
+DIST font-misc-ethiopic-1.0.5.tar.xz 222624 BLAKE2B 8184f7d6ebc72ac4524073670319ef26dcd09b1667973e46fb4756f61a4752104a974a44a8666d9bd011f56b3502746531ae8e608959e124068e4a3d5539ba16 SHA512 7732a828c005e3762b6383729134c5656fd575ac59288504d047fbe26e9965a80519a37b0cc4c6b89379a85a62160c5ea76017f790447a230c015aa7a9143ba0
diff --git a/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild b/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild
new file mode 100644
index 000000000000..fc918c94867e
--- /dev/null
+++ b/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+FONT_DIR="OTF"
+XORG_TARBALL_SUFFIX="xz"
+XORG_PACKAGE_NAME="misc-ethiopic"
+inherit xorg-3
+
+DESCRIPTION="Miscellaneous Ethiopic fonts"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-fontrootdir="${EPREFIX}/usr/share/fonts"
+
+ # This flag unexpectedly doesn't control whether the font (i.e. the .ttf file)
+ # is installed, but instead only controls whether mkfontscale/mkfontdir is
+ # run. I suspect this is a bug.
+ --disable-truetype-install
+)
+
+src_install() {
+ xorg-3_src_install
+
+ # TTF fonts are not supposed to be installed.
+ rm -r "${ED}/usr/share/fonts/TTF" || die
+}