summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/cairosvg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/cairosvg')
-rw-r--r--media-gfx/cairosvg/Manifest2
-rw-r--r--media-gfx/cairosvg/cairosvg-1.0.7.ebuild31
-rw-r--r--media-gfx/cairosvg/cairosvg-1.0.ebuild30
-rw-r--r--media-gfx/cairosvg/metadata.xml8
4 files changed, 71 insertions, 0 deletions
diff --git a/media-gfx/cairosvg/Manifest b/media-gfx/cairosvg/Manifest
new file mode 100644
index 000000000000..7bb700ec9bd6
--- /dev/null
+++ b/media-gfx/cairosvg/Manifest
@@ -0,0 +1,2 @@
+DIST CairoSVG-1.0.7.tar.gz 29648 SHA256 2ccdfd8cdfc6797da1f63d8f15fd76fa72d482d618a4807bb02f0b37662bca39 SHA512 1b10657f1e53b486f624ec00e952c3d2ba2f28b2a5d6cb6f66eb6441e8c51190bd75315e7a537d37eadff5ce4e0a52d3f4ebd7b36d81b2e9fd804ac92f2d83db WHIRLPOOL aa7affdc656444c0558bcc9be9b66fb385a81e33d60c04aad81930041096782ecbbc40a4e26c4c76e1580d882411c3759244c85c23e0671dc48104224a99ba18
+DIST CairoSVG-1.0.tar.gz 28573 SHA256 65f613e9521c37066b92e24532f702dbf4b7049ce0fa5fb75d21afa467a38b9b SHA512 26046de33feb5d7cbd8438d5fdf7f0e86e4f252c21478b51e764d7bf7800c8392a11a42a87666af6e008ad1e09f0749b57d06c566101d2a3e630e151703a3bb9 WHIRLPOOL 166c14d1c0ec9c1c455ded7c69c60940d102224c00a9bf1c6882ab1134b2a1eec415c9fe1f82bf9921a84feb8bc8f1055aa38830916dae233783fae551b31cb3
diff --git a/media-gfx/cairosvg/cairosvg-1.0.7.ebuild b/media-gfx/cairosvg/cairosvg-1.0.7.ebuild
new file mode 100644
index 000000000000..84daf3f84cd9
--- /dev/null
+++ b/media-gfx/cairosvg/cairosvg-1.0.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="CairoSVG"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple cairo based SVG converter with support for PDF, PostScript and PNG formats"
+HOMEPAGE="http://cairosvg.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/tinycss[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/cairocffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( NEWS.rst README.rst TODO.rst )
diff --git a/media-gfx/cairosvg/cairosvg-1.0.ebuild b/media-gfx/cairosvg/cairosvg-1.0.ebuild
new file mode 100644
index 000000000000..f63e8d2bcfee
--- /dev/null
+++ b/media-gfx/cairosvg/cairosvg-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+MY_PN="CairoSVG"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple cairo based SVG converter with support for PDF, PostScript and PNG formats"
+HOMEPAGE="http://cairosvg.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/tinycss[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( NEWS.rst README.rst TODO.rst )
diff --git a/media-gfx/cairosvg/metadata.xml b/media-gfx/cairosvg/metadata.xml
new file mode 100644
index 000000000000..995bd87ffbb2
--- /dev/null
+++ b/media-gfx/cairosvg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="pypi">CairoSVG</remote-id>
+ </upstream>
+</pkgmetadata>