summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/drqueue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/drqueue')
-rw-r--r--media-gfx/drqueue/Manifest1
-rw-r--r--media-gfx/drqueue/drqueue-0.64.4-r1.ebuild150
-rw-r--r--media-gfx/drqueue/drqueue-9999.ebuild140
-rw-r--r--media-gfx/drqueue/files/drqueue-0.64.3-compile-flags.patch15
-rw-r--r--media-gfx/drqueue/files/drqueue-0.64.3-etc-confd-drqmd20
-rw-r--r--media-gfx/drqueue/files/drqueue-0.64.3-etc-confd-drqsd20
-rw-r--r--media-gfx/drqueue/files/drqueue-0.64.3-etc-envd-02drqueue5
-rwxr-xr-xmedia-gfx/drqueue/files/drqueue-0.64.3-etc-initd-drqmd26
-rwxr-xr-xmedia-gfx/drqueue/files/drqueue-0.64.3-etc-initd-drqsd25
-rw-r--r--media-gfx/drqueue/files/drqueue-0.64.3-sconstruct.patch11
-rw-r--r--media-gfx/drqueue/files/drqueue-0.64.4-fpic.patch11
-rw-r--r--media-gfx/drqueue/files/drqueue-0.64.4-git.patch17
-rw-r--r--media-gfx/drqueue/metadata.xml8
13 files changed, 449 insertions, 0 deletions
diff --git a/media-gfx/drqueue/Manifest b/media-gfx/drqueue/Manifest
new file mode 100644
index 000000000000..594c4753ac38
--- /dev/null
+++ b/media-gfx/drqueue/Manifest
@@ -0,0 +1 @@
+DIST drqueue.0.64.4.tgz 619577 SHA256 a8753a41558e2d5af48a10071cb4a201b5e12f674d25127593bcf8a4bd1f634d SHA512 3ba014fe8ceb8b35658126455cdab9ccbd3d9343124267d61d128d94fd48fe695da724936b2ce7153ee620cf27f3e9e8fd0eb819fa4916c930a3c06a05efc680 WHIRLPOOL ca90cc9d3c47f4d2e3694880cb666175a39344114a3095ddc72f53521e2c0a7be928bb3dd359060695ffc8e12b6995b2740ccbed659f89ad4c09d5b7ee7b34f4
diff --git a/media-gfx/drqueue/drqueue-0.64.4-r1.ebuild b/media-gfx/drqueue/drqueue-0.64.4-r1.ebuild
new file mode 100644
index 000000000000..74fa8ae064d3
--- /dev/null
+++ b/media-gfx/drqueue/drqueue-0.64.4-r1.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 user
+
+DESCRIPTION="Render farm managing software"
+HOMEPAGE="http://www.drqueue.org/"
+SRC_URI="http://drqueue.org/files/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X python ruby"
+
+RDEPEND="X? ( x11-libs/gtk+:2 )
+ ruby? ( dev-lang/ruby )
+ app-shells/tcsh"
+
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )
+ python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
+ >=dev-util/scons-0.97"
+
+S=${WORKDIR}/DrQueue-${PV}
+
+PATCHES=( "${FILESDIR}"/${P}-fpic.patch
+ "${FILESDIR}"/${P}-git.patch )
+
+pkg_setup() {
+ enewgroup drqueue
+ enewuser drqueue -1 /bin/bash /dev/null daemon,drqueue
+
+ use python && python-single-r1_pkg_setup
+}
+
+python_prepare() {
+ distutils-r1_python_prepare
+ # Workaround broken SWIG path
+ ln -s ../libdrqueue python/libdrqueue || die
+}
+
+src_compile() {
+ if use X; then
+ scons ${MAKEOPTS} build_drman=yes || die "scons failed"
+ else
+ scons ${MAKEOPTS} build_drqman=no || die "scons failed"
+ fi
+
+ if use python; then
+ einfo "compiling python bindings"
+ pushd "${S}"/python/ > /dev/null
+ distutils-r1_src_compile
+ popd > /dev/null
+ fi
+
+ if use ruby; then
+ einfo "compiling ruby bindings"
+ cd "${S}"/ruby/
+ ruby extconf.rb
+ emake || die "emake failed"
+ fi
+}
+
+pkg_preinst() {
+ # stop daemons since script is being updated
+ [ -n "$(pidof drqsd)" -a -x /etc/init.d/drqsd ] && \
+ /etc/init.d/drqsd stop
+ [ -n "$(pidof drqmd)" -a -x /etc/init.d/drqmd ] && \
+ /etc/init.d/drqmd stop
+}
+
+src_install() {
+ dodir /var/lib
+ scons PREFIX="${D}"/var/lib install || die "install failed"
+
+ # not really needed
+ rm -R "${D}"/var/lib/drqueue/bin/viewcmd || die "rm failed"
+
+ # install {conf,init,env}.d files
+ for i in drqmd drqsd ; do
+ newinitd "${FILESDIR}"/${PN}-0.64.3-etc-initd-${i} ${i} || die "newinitd failed"
+ newconfd "${FILESDIR}"/${PN}-0.64.3-etc-confd-${i} ${i} || die "newconfd failed"
+ done
+ newenvd "${FILESDIR}"/${PN}-0.64.3-etc-envd-02drqueue 02drqueue || die "newenvd failed"
+
+ # create the drqueue pid directory
+ dodir /var/run/drqueue
+ keepdir /var/run/drqueue
+
+ # move logs dir to /var/log
+ dodir /var/log
+ mv "${D}"/var/lib/drqueue/logs "${D}"/var/log/drqueue
+
+ # fix bins and make links for /usr/bin
+ dodir /usr/bin
+ local commands=( blockhost cjob jobfinfo \
+ jobinfo master requeue sendjob slave )
+ if use X ; then
+ commands=( ${commands[@]} drqman )
+ else
+ # Remove drqman leftovers
+ for i in etc/drqman.rc etc/drqman.conf bin/drqman ; do
+ rm -v "${D}"/var/lib/drqueue/$i || die "rm failed"
+ done
+ fi
+ for cmd in ${commands[@]} ; do
+ sed -e 's|SHLIB=\$DRQUEUE_ROOT/bin/shlib|SHLIB=/var/lib/drqueue/bin/shlib|' \
+ -i "${D}"var/lib/drqueue/bin/${cmd} || die "sed failed"
+ dosym /var/lib/drqueue/bin/${cmd} /usr/bin/ \
+ || die "dosym failed"
+ done
+
+ # install documentation
+ dodoc AUTHORS ChangeLog INSTALL \
+ NEWS README README.mentalray \
+ README.python setenv || die "dodoc failed"
+
+ if use python; then
+ cd "${S}"/python/
+ distutils-r1_src_install
+ dodir /var/lib/${PN}/python
+
+ # Install DRKeewee web service and example python scripts
+ insinto /var/lib/${PN}/python
+ doins -r DrKeewee examples || die "doins failed"
+ python_fix_shebang "${ED}var/lib/${PN}/python"
+ fi
+
+ if use ruby; then
+ cd "${S}"/ruby/
+ emake DESTDIR="${D}" install || die "emake failed"
+ fi
+}
+
+pkg_postinst() {
+ einfo "Edit /etc/conf.d/drqsd /etc/env.d/02drqueue"
+ einfo "and /etc/conf.d/drqmd DRQUEUE_MASTER=\"hostname\""
+ einfo "to reflect your master's hostname."
+ if use python ; then
+ einfo
+ einfo "DrKeewee can be found in /var/lib/drqueue/python"
+ fi
+}
diff --git a/media-gfx/drqueue/drqueue-9999.ebuild b/media-gfx/drqueue/drqueue-9999.ebuild
new file mode 100644
index 000000000000..b9b529593166
--- /dev/null
+++ b/media-gfx/drqueue/drqueue-9999.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 git-2 user
+
+DESCRIPTION="Render farm managing software"
+HOMEPAGE="http://www.drqueue.org/"
+EGIT_REPO_URI="https://ssl.drqueue.org/git/${PN}.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="X python ruby"
+
+RDEPEND="X? ( x11-libs/gtk+:2 )
+ ruby? ( dev-lang/ruby )
+ app-shells/tcsh"
+
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )
+ python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
+ >=dev-util/scons-0.97"
+
+pkg_setup() {
+ enewgroup drqueue
+ enewuser drqueue -1 /bin/bash /dev/null daemon,drqueue
+
+ use python && python_pkg_setup
+}
+
+src_compile() {
+ if use X; then
+ scons ${MAKEOPTS} build_drman=yes || die "scons failed"
+ else
+ scons ${MAKEOPTS} build_drqman=no || die "scons failed"
+ fi
+
+ if use python; then
+ einfo "compiling python bindings"
+ pushd "${S}"/python/ > /dev/null
+ distutils-r1_src_compile
+ popd > /dev/null
+ fi
+
+ if use ruby; then
+ einfo "compiling ruby bindings"
+ cd "${S}"/ruby/
+ ruby extconf.rb
+ emake || die "emake failed"
+ fi
+}
+
+pkg_preinst() {
+ # stop daemons since script is being updated
+ [ -n "$(pidof drqsd)" -a -x /etc/init.d/drqsd ] && \
+ /etc/init.d/drqsd stop
+ [ -n "$(pidof drqmd)" -a -x /etc/init.d/drqmd ] && \
+ /etc/init.d/drqmd stop
+}
+
+src_install() {
+ dodir /var/lib
+ scons PREFIX="${D}"/var/lib install || die "install failed"
+
+ # not really needed
+ rm -R "${D}"/var/lib/drqueue/bin/viewcmd || die "rm failed"
+
+ # install {conf,init,env}.d files
+ for i in drqmd drqsd ; do
+ newinitd "${FILESDIR}"/${PN}-0.64.3-etc-initd-${i} ${i} || die "newinitd failed"
+ newconfd "${FILESDIR}"/${PN}-0.64.3-etc-confd-${i} ${i} || die "newconfd failed"
+ done
+ newenvd "${FILESDIR}"/${PN}-0.64.3-etc-envd-02drqueue 02drqueue || die "newenvd failed"
+
+ # create the drqueue pid directory
+ dodir /var/run/drqueue
+ keepdir /var/run/drqueue
+
+ # move logs dir to /var/log
+ dodir /var/log
+ mv "${D}"/var/lib/drqueue/logs "${D}"/var/log/drqueue
+
+ # fix bins and make links for /usr/bin
+ dodir /usr/bin
+ local commands=( blockhost cjob jobfinfo \
+ jobinfo master requeue sendjob slave )
+ if use X ; then
+ commands=( ${commands[@]} drqman )
+ else
+ # Remove drqman leftovers
+ for i in etc/drqman.rc etc/drqman.conf bin/drqman ; do
+ rm -v "${D}"/var/lib/drqueue/$i || die "rm failed"
+ done
+ fi
+ for cmd in ${commands[@]} ; do
+ sed -e 's|SHLIB=\$DRQUEUE_ROOT/bin/shlib|SHLIB=/var/lib/drqueue/bin/shlib|' \
+ -i "${D}"var/lib/drqueue/bin/${cmd} || die "sed failed"
+ dosym /var/lib/drqueue/bin/${cmd} /usr/bin/ \
+ || die "dosym failed"
+ done
+
+ # install documentation
+ dodoc AUTHORS ChangeLog INSTALL \
+ NEWS README README.mentalray \
+ README.python README.shell_variables \
+ setenv || die "dodoc failed"
+
+ if use python; then
+ cd "${S}"/python/
+ distutils-r1_src_install
+ dodir /var/lib/${PN}/python
+
+ # Install DRKeewee web service and example python scripts
+ insinto /var/lib/${PN}/python
+ doins -r DrKeewee examples || die "doins failed"
+ python_fix_shebang "${ED}var/lib/${PN}/python"
+ fi
+
+ if use ruby; then
+ cd "${S}"/ruby/
+ emake DESTDIR="${D}" install || die "emake failed"
+ fi
+}
+
+pkg_postinst() {
+ einfo "Edit /etc/conf.d/drqsd /etc/env.d/02drqueue"
+ einfo "and /etc/conf.d/drqmd DRQUEUE_MASTER=\"hostname\""
+ einfo "to reflect your master's hostname."
+ if use python ; then
+ einfo
+ einfo "DrKeewee can be found in /var/lib/drqueue/python"
+ fi
+}
diff --git a/media-gfx/drqueue/files/drqueue-0.64.3-compile-flags.patch b/media-gfx/drqueue/files/drqueue-0.64.3-compile-flags.patch
new file mode 100644
index 000000000000..eeee2a67f752
--- /dev/null
+++ b/media-gfx/drqueue/files/drqueue-0.64.3-compile-flags.patch
@@ -0,0 +1,15 @@
+--- SConstruct_BACKUP 2009-12-31 22:53:23.000000000 +0100
++++ SConstruct 2009-12-31 22:57:48.000000000 +0100
+@@ -102,9 +102,10 @@
+ env_lib.Append (CPPPATH=['.','libdrqueue'])
+ env_lib.Append (CPPDEFINES = Split ('-DCOMM_REPORT -D_GNU_SOURCE ' \
+ + '-D_NO_COMPUTER_POOL_SEMAPHORES -D_NO_COMPUTER_SEMAPHORES'),
+- CPPFLAGS = Split ('-g -O0'),
++ CFLAGS = Split(os.environ.get('CFLAGS', '')),
+ CXXFLAGS = ['-D__CPLUSPLUS',Split(env_lib.subst('$CCFLAGS')),
+- Split(env_lib.subst('$CPPDEFINES'))])
++ Split(env_lib.subst('$CPPDEFINES')),
++ Split(os.environ.get('CXXFLAGS', ''))])
+
+ print "Platform is: ",sys.platform
+ if sys.platform == "linux2":
diff --git a/media-gfx/drqueue/files/drqueue-0.64.3-etc-confd-drqmd b/media-gfx/drqueue/files/drqueue-0.64.3-etc-confd-drqmd
new file mode 100644
index 000000000000..c6580b279b08
--- /dev/null
+++ b/media-gfx/drqueue/files/drqueue-0.64.3-etc-confd-drqmd
@@ -0,0 +1,20 @@
+# /etc/conf.d/drqmd config file for /etc/init.d/drqmd
+
+# enter your master hostname here
+DRQUEUE_MASTER="127.0.0.1"
+
+# this is the drqueue root dir, do not change below here unless you know what you're doing
+DRQUEUE_ROOT="/var/lib/drqueue"
+DRQUEUE_LOGS="/var/log/drqueue"
+
+# set the environmental variables for drqueue
+ENV="env DRQUEUE_ROOT=${DRQUEUE_ROOT} DRQUEUE_MASTER=${DRQUEUE_MASTER} DRQUEUE_LOGS=${DRQUEUE_LOGS}"
+
+# this is the drqueue master executable
+DRQUEUEMASTER_EXEC="/usr/bin/master"
+
+# this is where drqueue master will store its pid file
+DRQUEUEMASTER_PIDFILE="/var/run/drqueue/drqmd.pid"
+
+
+
diff --git a/media-gfx/drqueue/files/drqueue-0.64.3-etc-confd-drqsd b/media-gfx/drqueue/files/drqueue-0.64.3-etc-confd-drqsd
new file mode 100644
index 000000000000..d65b05555786
--- /dev/null
+++ b/media-gfx/drqueue/files/drqueue-0.64.3-etc-confd-drqsd
@@ -0,0 +1,20 @@
+# /etc/conf.d/drqsd config file for /etc/init.d/drqsd
+
+# enter your master hostname here
+DRQUEUE_MASTER="127.0.0.1"
+
+# this is the drqueue root dir, do not change below here unless you know what you're doing
+DRQUEUE_ROOT="/var/lib/drqueue"
+DRQUEUE_LOGS="/var/log/drqueue"
+
+# list of pools the slave is belonging to ("blender:mentalray:bla123")
+DRQUEUE_POOL=""
+
+# set the environmental variables for drqueue
+ENV="env DRQUEUE_ROOT=${DRQUEUE_ROOT} DRQUEUE_MASTER=${DRQUEUE_MASTER} DRQUEUE_LOGS=${DRQUEUE_LOGS} DRQUEUE_POOL=${DRQUEUE_POOL}"
+
+# this is the drqueue slave executable
+DRQUEUESLAVE_EXEC="/usr/bin/slave"
+
+# this is where drqueue slave will store its pid file
+DRQUEUESLAVE_PIDFILE="/var/run/drqueue/drqsd.pid"
diff --git a/media-gfx/drqueue/files/drqueue-0.64.3-etc-envd-02drqueue b/media-gfx/drqueue/files/drqueue-0.64.3-etc-envd-02drqueue
new file mode 100644
index 000000000000..cb368bf79cf3
--- /dev/null
+++ b/media-gfx/drqueue/files/drqueue-0.64.3-etc-envd-02drqueue
@@ -0,0 +1,5 @@
+# environment variable for DrQueue
+DRQUEUE_MASTER="127.0.0.1"
+DRQUEUE_ROOT="/var/lib/drqueue"
+DRQUEUE_LOGS="/var/log/drqueue"
+
diff --git a/media-gfx/drqueue/files/drqueue-0.64.3-etc-initd-drqmd b/media-gfx/drqueue/files/drqueue-0.64.3-etc-initd-drqmd
new file mode 100755
index 000000000000..ff4ae9250b54
--- /dev/null
+++ b/media-gfx/drqueue/files/drqueue-0.64.3-etc-initd-drqmd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ [ -e "${DRQUEUEMASTER_PIDFILE}" ] && rm -f ${DRQUEUEMASTER_PIDFILE} &>/dev/null
+ ebegin "Starting drqmd"
+
+ chown drqueue `dirname ${DRQUEUEMASTER_PIDFILE}` &>/dev/null
+ ${ENV} /sbin/start-stop-daemon -b --start --quiet --startas /usr/bin/master \
+ --pidfile ${DRQUEUEMASTER_PIDFILE} --make-pidfile
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping drqmd"
+ pkill -u root,drqueue master
+ start-stop-daemon --stop --quiet --pidfile "${DRQUEUEMASTER_PIDFILE}"
+ rm -f "${DRQUEUEMASTER_PIDFILE}"
+ eend $?
+}
+
+
diff --git a/media-gfx/drqueue/files/drqueue-0.64.3-etc-initd-drqsd b/media-gfx/drqueue/files/drqueue-0.64.3-etc-initd-drqsd
new file mode 100755
index 000000000000..65b3ced86374
--- /dev/null
+++ b/media-gfx/drqueue/files/drqueue-0.64.3-etc-initd-drqsd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ [ -e "${DRQUEUESLAVE_PIDFILE}" ] && rm -f ${DRQUEUESLAVE_PIDFILE} &>/dev/null
+
+ ebegin "Starting drqsd"
+ chown drqueue `dirname ${DRQUEUESLAVE_PIDFILE}` &>/dev/null
+ ${ENV} /sbin/start-stop-daemon -b --start --quiet --startas /usr/bin/slave \
+ --pidfile ${DRQUEUESLAVE_PIDFILE} --make-pidfile
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping drqsd"
+ pkill -u root,drqueue slave
+ start-stop-daemon --stop --quiet --pidfile "${DRQUEUESLAVE_PIDFILE}"
+ rm -f "${DRQUEUESLAVE_PIDFILE}"
+ eend $?
+}
+
diff --git a/media-gfx/drqueue/files/drqueue-0.64.3-sconstruct.patch b/media-gfx/drqueue/files/drqueue-0.64.3-sconstruct.patch
new file mode 100644
index 000000000000..87b4608300b1
--- /dev/null
+++ b/media-gfx/drqueue/files/drqueue-0.64.3-sconstruct.patch
@@ -0,0 +1,11 @@
+--- drqueue-0.64.3/SConstruct 2007-07-22 07:34:40.000000000 +0100
++++ drqueue-0.64.3/SConstruct.patched 2007-08-15 18:59:54.000000000 +0100
+@@ -108,7 +108,7 @@ env_lib.Append (CPPDEFINES = Split ('-DC
+
+ print "Platform is: ",sys.platform
+ if sys.platform == "linux2":
+- env_lib.Append (CPPDEFINES = Split ('-D__LINUX'))
++ env_lib.Append (CPPDEFINES = Split ('-D__LINUX'),CFLAGS = Split ('-fPIC'))
+ elif sys.platform == "darwin":
+ env_lib.Append (CPPDEFINES = Split ('-D__OSX'))
+ if env_lib.get('universal_binary'):
diff --git a/media-gfx/drqueue/files/drqueue-0.64.4-fpic.patch b/media-gfx/drqueue/files/drqueue-0.64.4-fpic.patch
new file mode 100644
index 000000000000..217728f181a2
--- /dev/null
+++ b/media-gfx/drqueue/files/drqueue-0.64.4-fpic.patch
@@ -0,0 +1,11 @@
+--- DrQueue-0.64.4/SConstruct 2012-10-29 17:11:02.462831439 +0100
++++ DrQueue-0.64.4/SConstruct 2012-10-29 17:11:08.746752880 +0100
+@@ -141,7 +141,7 @@
+
+ print "Platform is: ",sys.platform
+ if sys.platform == "linux2":
+- env_lib.Append (CPPDEFINES = Split ('-D__LINUX'))
++ env_lib.Append (CPPDEFINES = Split ('-D__LINUX'),CFLAGS = Split ('-fPIC'))
+ elif sys.platform == "darwin":
+ env_lib.Append (CPPDEFINES = Split ('-D__OSX'))
+ if env_lib.get('universal_binary'):
diff --git a/media-gfx/drqueue/files/drqueue-0.64.4-git.patch b/media-gfx/drqueue/files/drqueue-0.64.4-git.patch
new file mode 100644
index 000000000000..3d87ceef6345
--- /dev/null
+++ b/media-gfx/drqueue/files/drqueue-0.64.4-git.patch
@@ -0,0 +1,17 @@
+--- DrQueue-0.64.4/SConstruct 2012-10-29 16:40:29.396747920 +0100
++++ DrQueue-0.64.4/SConstruct 2012-10-29 16:49:00.676356045 +0100
+@@ -79,8 +79,12 @@
+ print("Not a Git repository. Can't fetch commit id.")
+ commit_string = ""
+ else:
+- commit_string = gitlog.communicate()[0].split("\n")[0].split(" ")[1]
+- print("Current Git commit id is: "+commit_string)
++ output = gitlog.communicate()[0]
++ if output:
++ commit_string = output.split("\n")[0].split(" ")[1]
++ print("Current Git commit id is: "+commit_string)
++ else:
++ commit_string = ""
+ return commit_string
+
+ def write_git_rev(commit_id):
diff --git a/media-gfx/drqueue/metadata.xml b/media-gfx/drqueue/metadata.xml
new file mode 100644
index 000000000000..16bcc9f800a2
--- /dev/null
+++ b/media-gfx/drqueue/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>