summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-21 21:13:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-21 23:19:56 +0100
commit66125082f84df7dfc165559b8f0c1dffaf41582f (patch)
tree51227ad460939cf4b9e5f8a41f3ffd80cc2fedb0 /media-gfx/exiv2
parentapp-office/libreoffice: curl: mitigate migration to OpenSSL on Linux (diff)
downloadgentoo-66125082f84df7dfc165559b8f0c1dffaf41582f.tar.gz
gentoo-66125082f84df7dfc165559b8f0c1dffaf41582f.tar.bz2
gentoo-66125082f84df7dfc165559b8f0c1dffaf41582f.zip
media-gfx/exiv2: Restore exiv2lib target
Closes: https://bugs.gentoo.org/917483 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/exiv2-0.28.1-r1.ebuild132
-rw-r--r--media-gfx/exiv2/files/exiv2-0.28.1-exiv2lib.patch31
2 files changed, 163 insertions, 0 deletions
diff --git a/media-gfx/exiv2/exiv2-0.28.1-r1.ebuild b/media-gfx/exiv2/exiv2-0.28.1-r1.ebuild
new file mode 100644
index 000000000000..a099676b0818
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.28.1-r1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="https://exiv2.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Exiv2/exiv2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+# Upstream hope to have stable ABI in 1.0. Until then, go off ${PV}.
+# We may be able to change it to $(ver_cut 1-2) once e.g.
+# https://github.com/Exiv2/exiv2/pull/917 is merged.
+SLOT="0/$(ver_cut 1-2)"
+IUSE="+bmff doc examples nls +png test webready +xmp"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ webready? (
+ net-misc/curl[${MULTILIB_USEDEP}]
+ )
+ xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${DEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ test? ( ${PYTHON_DEPS} )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( README.md doc/ChangeLog doc/cmd.txt )
+
+# https://github.com/Exiv2/exiv2/pull/2832
+PATCHES=( "${FILESDIR}/${P}-exiv2lib.patch" ) # bug 917483
+
+pkg_setup() {
+ if use doc || use test ; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ cmake_src_prepare
+
+ sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_BUILD_SAMPLES=NO
+ -DEXIV2_ENABLE_BROTLI=OFF
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_INIH=OFF # multilib/libdir logic is broken
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ -DEXIV2_ENABLE_BMFF=$(usex bmff)
+
+ # We let users control this.
+ -DBUILD_WITH_CCACHE=OFF
+ # Our toolchain sets this by default.
+ -DBUILD_WITH_STACK_PROTECTOR=OFF
+
+ $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_DOC=$(usex doc))
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_UNIT_TESTS=$(usex test))
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ if use doc || use test ; then
+ mycmakeargs+=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && eninja doc
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ cd "${BUILD_DIR}"/bin || die
+ ./unit_tests || die "Failed to run tests"
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}
diff --git a/media-gfx/exiv2/files/exiv2-0.28.1-exiv2lib.patch b/media-gfx/exiv2/files/exiv2-0.28.1-exiv2lib.patch
new file mode 100644
index 000000000000..dba8fd3e2896
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.28.1-exiv2lib.patch
@@ -0,0 +1,31 @@
+From 4f6d0b806714a702ccbe9e10c5155eb6a1699380 Mon Sep 17 00:00:00 2001
+From: Pino Toscano <toscano.pino@tiscali.it>
+Date: Tue, 14 Nov 2023 07:23:32 +0100
+Subject: [PATCH] cmake: restore a "exiv2lib" target
+
+Commit a8c3455e5cd7ee65acc5f398581e1386f7df5108 and
+commit eb05551ed2d21079299f2f4da2f463df6857b884 changed the target of
+the exiv2 library ("exiv2lib"), exporting it in the "Exiv2" namespace,
+so making it usable as "Exiv2::exiv2lib" instead. An ALIAS to "exiv2lib"
+was added, however cmake does not install or export ALIAS targets [1].
+
+Hence, restore compatibility with the existing cmake users of exiv2:
+manually create an ALIAS target in the cmake config files after all the
+targets are loaded and checked.
+
+[1] https://cmake.org/cmake/help/latest/command/add_library.html
+---
+ cmake/exiv2Config.cmake.in | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/cmake/exiv2Config.cmake.in b/cmake/exiv2Config.cmake.in
+index 63c9362ff7..c9e2eba9b5 100644
+--- a/cmake/exiv2Config.cmake.in
++++ b/cmake/exiv2Config.cmake.in
+@@ -14,3 +14,6 @@ endif()
+ include("${CMAKE_CURRENT_LIST_DIR}/exiv2Export.cmake")
+
+ check_required_components(exiv2)
++
++# compatibility with non-aliased users
++add_library(exiv2lib ALIAS Exiv2::exiv2lib)