summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-29 20:18:41 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-29 20:18:41 +0100
commit52f1685f3f43b07195dc89da548aed2fe1d639c0 (patch)
tree5b489367a894a94bd82eecb540d8a8e593092906 /media-gfx/fr0st
parentwww-apache/passenger: add 5.0.25 (diff)
downloadgentoo-52f1685f3f43b07195dc89da548aed2fe1d639c0.tar.gz
gentoo-52f1685f3f43b07195dc89da548aed2fe1d639c0.tar.bz2
gentoo-52f1685f3f43b07195dc89da548aed2fe1d639c0.zip
media-gfx/fr0st: Fix problems at runtime (#564106, thanks a lot to Malcolm Lashley for finding the fix), port to new python eclasses, use wxGTK3.
Package-Manager: portage-2.2.27
Diffstat (limited to 'media-gfx/fr0st')
-rw-r--r--media-gfx/fr0st/files/fr0st-1.4-colour.patch9
-rw-r--r--media-gfx/fr0st/fr0st-1.4-r2.ebuild58
2 files changed, 67 insertions, 0 deletions
diff --git a/media-gfx/fr0st/files/fr0st-1.4-colour.patch b/media-gfx/fr0st/files/fr0st-1.4-colour.patch
new file mode 100644
index 000000000000..9fb17aadaab7
--- /dev/null
+++ b/media-gfx/fr0st/files/fr0st-1.4-colour.patch
@@ -0,0 +1,9 @@
+--- fr0stlib/gui/canvas.py~ 2011-05-14 19:58:25.000000000 +0200
++++ fr0stlib/gui/canvas.py 2016-02-20 17:47:25.853322560 +0100
+@@ -79,7 +79,7 @@
+
+ def SetBrush(self, FillColor, FillStyle):
+ r,g,b = FillColor
+- c = wx.Color(r,g,b, self.Opacity)
++ c = wx.Colour(r,g,b, self.Opacity)
+ self.Brush = wx.Brush(c)
diff --git a/media-gfx/fr0st/fr0st-1.4-r2.ebuild b/media-gfx/fr0st/fr0st-1.4-r2.ebuild
new file mode 100644
index 000000000000..b1da6b59610d
--- /dev/null
+++ b/media-gfx/fr0st/fr0st-1.4-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="3.0"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib python-single-r1 wxwidgets
+
+DESCRIPTION="A fractal flame editor"
+HOMEPAGE="http://fr0st.wordpress.com/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}.0/+download/${P}-src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/wxpython:${WX_GTK_VER}
+ >=media-gfx/flam3-3.0.1
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+pkg_setup() {
+ fr0st_libdir="/usr/$(get_libdir)/fr0st"
+ fr0st_sharedir="/usr/share/fr0st"
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-colour.patch #564106
+ python_fix_shebang .
+ need-wxwidgets unicode
+}
+
+src_install() {
+ insinto "${fr0st_sharedir}"
+ doins -r icons samples
+
+ insinto "${fr0st_libdir}"
+ doins -r fr0stlib
+
+ exeinto "${fr0st_libdir}"
+ doexe fr0st.py
+
+ dosym "${fr0st_libdir}"/fr0st.py /usr/bin/fr0st
+ dosym "${fr0st_sharedir}"/icons/fr0st.png /usr/share/pixmaps/fr0st.png
+
+ make_desktop_entry fr0st fr0st
+
+ dodoc changelog.txt
+}