summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2018-08-04 18:09:39 +0100
committerJonathan Scruggs <dracwyrm@gentoo.org>2018-08-04 19:21:37 +0100
commit74320c01dacb7c27d6901caac7ef67e47f0114e7 (patch)
treea1a1f08d175bafa29d96c69eda41082c374c0e23 /media-gfx/openvdb/files
parentsys-devel/binutils: Remove branch live ebuild (diff)
downloadgentoo-74320c01dacb7c27d6901caac7ef67e47f0114e7.tar.gz
gentoo-74320c01dacb7c27d6901caac7ef67e47f0114e7.tar.bz2
gentoo-74320c01dacb7c27d6901caac7ef67e47f0114e7.zip
media-gfx/openvdb: revision bump to fix FindBoost
Add patch from Dennis Schridde <devurandom@gmx.net> to fix finding boost with CMake 3.11 Closes: https://bugs.gentoo.org/652266 Closes: https://github.com/gentoo/gentoo/pull/9443
Diffstat (limited to 'media-gfx/openvdb/files')
-rw-r--r--media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch b/media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch
new file mode 100644
index 000000000000..12245be3e466
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-4.0.2-findboost-fix.patch
@@ -0,0 +1,11 @@
+--- openvdb-4.0.2/openvdb/python/CMakeLists.txt.orig 2018-07-12 20:29:50.745624805 +0200
++++ openvdb-4.0.2/openvdb/python/CMakeLists.txt 2018-07-12 20:30:10.452305180 +0200
+@@ -3,7 +3,7 @@
+
+ FIND_PACKAGE ( PythonInterp REQUIRED )
+ FIND_PACKAGE ( PythonLibs REQUIRED )
+-FIND_PACKAGE ( Boost ${MINIMUM_BOOST_VERSION} REQUIRED COMPONENTS python )
++FIND_PACKAGE ( Boost ${MINIMUM_BOOST_VERSION} REQUIRED COMPONENTS python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR} )
+
+
+ IF ( NOT OPENVDB_BUILD_CORE )