summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-08-18 16:18:56 +1000
committerSam James <sam@gentoo.org>2020-08-24 14:41:51 +0100
commitc91c00513d5e61359095c22d52072d726e5b7f49 (patch)
tree4bdf24fb06ba4668e9941b8e996222c2944287be /media-gfx/openvdb/files
parentmedia-gfx/openvdb: Fix optional boost python dependency (diff)
downloadgentoo-c91c00513d5e61359095c22d52072d726e5b7f49.tar.gz
gentoo-c91c00513d5e61359095c22d52072d726e5b7f49.tar.bz2
gentoo-c91c00513d5e61359095c22d52072d726e5b7f49.zip
media-gfx/openvdb: Version bump to 6.2.1
Version bump to openvdb 6.2.1, requiring an additional use flag for abi6-compat. This version requires cmake 3.16 or higher. Other changes: * Compared to version 5, the gnuinstalldirs patch no longer needs BLOSC_LOCATION, GLFW3_LOCATION or TBB_LOCATION so these have been removed. * The new multilib header patch needs to know the CHOST so it is set in the arguments passed to cmake. * USE_GLFW3 is no longer used by the build system so it has been removed also. * Update the github upstream source as dreamworksanimation now redirects to AcademySoftwareFoundation. Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/openvdb/files')
-rw-r--r--media-gfx/openvdb/files/openvdb-6.2.1-fix-multilib-header-source.patch29
-rw-r--r--media-gfx/openvdb/files/openvdb-6.2.1-use-gnuinstalldirs.patch54
2 files changed, 83 insertions, 0 deletions
diff --git a/media-gfx/openvdb/files/openvdb-6.2.1-fix-multilib-header-source.patch b/media-gfx/openvdb/files/openvdb-6.2.1-fix-multilib-header-source.patch
new file mode 100644
index 000000000000..c6e2bae5dfae
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-6.2.1-fix-multilib-header-source.patch
@@ -0,0 +1,29 @@
+diff -Naur a/cmake/FindIlmBase.cmake b/cmake/FindIlmBase.cmake
+--- a/cmake/FindIlmBase.cmake 2020-02-02 01:03:55.000000000 +0800
++++ b/cmake/FindIlmBase.cmake 2020-02-02 01:09:05.000000000 +0800
+@@ -168,9 +168,15 @@
+ PATH_SUFFIXES include/OpenEXR OpenEXR
+ )
+
++if(EXISTS "/usr/include/${CHOST}/OpenEXR/IlmBaseConfig.h")
++ set(_ILMBASE_HEADERS "/usr/include/${CHOST}/OpenEXR")
++else()
++ set(_ILMBASE_HEADERS ${IlmBase_INCLUDE_DIR})
++endif()
++
+ if(EXISTS "${IlmBase_INCLUDE_DIR}/IlmBaseConfig.h")
+ # Get the ILMBASE version information from the config header
+- file(STRINGS "${IlmBase_INCLUDE_DIR}/IlmBaseConfig.h"
++ file(STRINGS "${_ILMBASE_HEADERS}/IlmBaseConfig.h"
+ _ilmbase_version_major_string REGEX "#define ILMBASE_VERSION_MAJOR "
+ )
+ string(REGEX REPLACE "#define ILMBASE_VERSION_MAJOR" ""
+@@ -178,7 +184,7 @@
+ )
+ string(STRIP "${_ilmbase_version_major_string}" IlmBase_VERSION_MAJOR)
+
+- file(STRINGS "${IlmBase_INCLUDE_DIR}/IlmBaseConfig.h"
++ file(STRINGS "${_ILMBASE_HEADERS}/IlmBaseConfig.h"
+ _ilmbase_version_minor_string REGEX "#define ILMBASE_VERSION_MINOR "
+ )
+ string(REGEX REPLACE "#define ILMBASE_VERSION_MINOR" ""
diff --git a/media-gfx/openvdb/files/openvdb-6.2.1-use-gnuinstalldirs.patch b/media-gfx/openvdb/files/openvdb-6.2.1-use-gnuinstalldirs.patch
new file mode 100644
index 000000000000..ac73d82f9c34
--- /dev/null
+++ b/media-gfx/openvdb/files/openvdb-6.2.1-use-gnuinstalldirs.patch
@@ -0,0 +1,54 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2020-01-08 22:16:00.493079361 +0800
++++ b/CMakeLists.txt 2020-01-08 22:16:44.790285583 +0800
+@@ -252,6 +252,8 @@
+
+ enable_testing()
+
++INCLUDE ( GNUInstallDirs )
++
+ # Add our cmake modules
+
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
+diff -Naur a/openvdb/CMakeLists.txt b/openvdb/CMakeLists.txt
+--- a/openvdb/CMakeLists.txt 2020-01-08 22:16:07.362646127 +0800
++++ b/openvdb/CMakeLists.txt 2020-01-08 22:19:54.638308684 +0800
+@@ -492,7 +492,7 @@
+ install(TARGETS
+ openvdb_static
+ DESTINATION
+- lib
++ ${CMAKE_INSTALL_LIBDIR}
+ )
+ endif()
+
+@@ -500,14 +500,14 @@
+ if(WIN32)
+ install(TARGETS
+ openvdb_shared
+- RUNTIME DESTINATION bin COMPONENT Runtime
+- ARCHIVE DESTINATION lib COMPONENT Runtime
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT Runtime
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Runtime
+ )
+ else()
+ install(TARGETS
+ openvdb_shared
+ DESTINATION
+- lib
++ ${CMAKE_INSTALL_LIBDIR}
+ )
+ endif()
+ endif()
+diff -Naur a/openvdb/python/CMakeLists.txt b/openvdb/python/CMakeLists.txt
+--- a/openvdb/python/CMakeLists.txt 2020-01-08 22:16:14.452199013 +0800
++++ b/openvdb/python/CMakeLists.txt 2020-01-08 22:21:45.311324663 +0800
+@@ -232,7 +232,7 @@
+ ${PYOPENVDB_INSTALL_DIRECTORY}
+ )
+
+-install(FILES ${PYTHON_PUBLIC_INCLUDE_NAMES} DESTINATION include/openvdb/python)
++install(FILES ${PYTHON_PUBLIC_INCLUDE_NAMES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/openvdb/python)
+
+ # pytest
+