summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-08-18 15:15:27 +1000
committerSam James <sam@gentoo.org>2020-08-24 14:41:51 +0100
commit604c23abcca4ef574b644ca59c52b36e18faf06e (patch)
tree6fc14f6b9e89b104205f8d502e2a60f3cc8b3853 /media-gfx/openvdb
parentmedia-gfx/openvdb: Ensure user chooses appropriate abi version (diff)
downloadgentoo-604c23abcca4ef574b644ca59c52b36e18faf06e.tar.gz
gentoo-604c23abcca4ef574b644ca59c52b36e18faf06e.tar.bz2
gentoo-604c23abcca4ef574b644ca59c52b36e18faf06e.zip
media-gfx/openvdb: Fix optional boost python dependency
If openvdb is built with the python USE flag, then it is necessary to build boost with python. Failure to do so produces compile failures. Use the ? operator to ensure that this occurs Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/openvdb')
-rw-r--r--media-gfx/openvdb/openvdb-4.0.2-r3.ebuild2
-rw-r--r--media-gfx/openvdb/openvdb-5.2.0-r1.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild b/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
index a34fc012d959..e31d95d616cb 100644
--- a/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
+++ b/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
@@ -38,7 +38,7 @@ RDEPEND="
python? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
- dev-libs/boost:=[python,${PYTHON_MULTI_USEDEP}]
+ dev-libs/boost:=[python?,${PYTHON_MULTI_USEDEP}]
dev-python/numpy[${PYTHON_MULTI_USEDEP}]
')
)"
diff --git a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
index 4a84ca540d1c..3b4864557cf9 100644
--- a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
+++ b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
@@ -36,7 +36,7 @@ RDEPEND="
python? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
- dev-libs/boost:=[python,${PYTHON_MULTI_USEDEP}]
+ dev-libs/boost:=[python?,${PYTHON_MULTI_USEDEP}]
dev-python/numpy[${PYTHON_MULTI_USEDEP}]
')
)"