summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-30 10:31:27 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-30 14:38:18 +0200
commit10b810d6c3c0507b819529b7bac401049ecbbdcd (patch)
treeedbb17e8b1842d0cc43679fa00a37b4deb962032 /media-gfx
parentmedia-gfx/mandelbulber: fix dependency, bug #935157 (diff)
downloadgentoo-10b810d6c3c0507b819529b7bac401049ecbbdcd.tar.gz
gentoo-10b810d6c3c0507b819529b7bac401049ecbbdcd.tar.bz2
gentoo-10b810d6c3c0507b819529b7bac401049ecbbdcd.zip
media-gfx/qiv: add 2.3.3
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/qiv/Manifest1
-rw-r--r--media-gfx/qiv/qiv-2.3.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-gfx/qiv/Manifest b/media-gfx/qiv/Manifest
index fb4484480faf..3b37f705993e 100644
--- a/media-gfx/qiv/Manifest
+++ b/media-gfx/qiv/Manifest
@@ -1 +1,2 @@
DIST qiv-2.3.2.tgz 133614 BLAKE2B f06f36524db8cdde1baf3e118e8ceeeb654dd49a674b55d661255734c0bedaa765fcf8bb77b03d3c2bac8d75a9088b3290f1d802d670393b6795fee85dd4f778 SHA512 c4636591f79e8e4c13807433a4101a461e614439e497a5637b958bd9d0937b04515854483d4060d9b1004d6c6060b437d634fdbe491eb0747a660ba65240472d
+DIST qiv-2.3.3.tgz 139301 BLAKE2B 0167e074f859ef028e3b343a8e521573f953ba43b7bd78f58e8b337a558b0d48a3c857cccafa2d55384fb48afdc0735949d873de878eff18658f09b98700c61c SHA512 95b5f3759c03648dea1ea1eacaf3d38d808a6eff4d26edf711df0e20a741fc22a0c16bcd84b8740f1455f5d35db9c2b04392dff8b4e030ec3d3c05cd01886759
diff --git a/media-gfx/qiv/qiv-2.3.3.ebuild b/media-gfx/qiv/qiv-2.3.3.ebuild
new file mode 100644
index 000000000000..4f8d62d74f7e
--- /dev/null
+++ b/media-gfx/qiv/qiv-2.3.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs xdg
+
+DESCRIPTION="Quick Image Viewer"
+HOMEPAGE="https://spiegl.de/qiv/ https://codeberg.org/ciberandy/qiv"
+SRC_URI="https://spiegl.de/qiv/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~mips ~x86"
+IUSE="exif lcms magic"
+
+RDEPEND="
+ media-libs/imlib2[X]
+ >=x11-libs/gtk+-2.12:2
+ exif? ( media-libs/libexif )
+ lcms? (
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/tiff:=
+ )
+ magic? ( sys-apps/file )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' \
+ Makefile || die
+
+ if ! use exif ; then
+ sed -i 's/^EXIF =/#\0/' Makefile || die
+ fi
+
+ if ! use lcms ; then
+ sed -i 's/^LCMS =/#\0/' Makefile || die
+ fi
+
+ if ! use magic ; then
+ sed -i 's/^MAGIC =/#\0/' Makefile || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin qiv
+ doman qiv.1
+ dodoc Changelog contrib/qiv-command.example README README.TODO
+
+ domenu qiv.desktop
+ doicon qiv.png
+}