summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-09-13 10:57:20 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-09-13 10:57:32 +0200
commita649fadef849ee3a6fb4e2c516aa6e2ee5eee1f5 (patch)
tree91d6ae648581acdabed93b87f6ae45012dcfeada /media-gfx
parentmedia-gfx/pngcheck: drop 3.0.2 (diff)
downloadgentoo-a649fadef849ee3a6fb4e2c516aa6e2ee5eee1f5.tar.gz
gentoo-a649fadef849ee3a6fb4e2c516aa6e2ee5eee1f5.tar.bz2
gentoo-a649fadef849ee3a6fb4e2c516aa6e2ee5eee1f5.zip
media-gfx/prusaslicer: fixed compilation with wxgtk 3.2.5
Closes: https://bugs.gentoo.org/938508 Bug: https://bugs.gentoo.org/938508 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.8.0-wxwidgets-3.2.4.patch28
-rw-r--r--media-gfx/prusaslicer/prusaslicer-2.8.0.ebuild1
-rw-r--r--media-gfx/prusaslicer/prusaslicer-9999.ebuild1
3 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.8.0-wxwidgets-3.2.4.patch b/media-gfx/prusaslicer/files/prusaslicer-2.8.0-wxwidgets-3.2.4.patch
new file mode 100644
index 000000000000..d7c700662b72
--- /dev/null
+++ b/media-gfx/prusaslicer/files/prusaslicer-2.8.0-wxwidgets-3.2.4.patch
@@ -0,0 +1,28 @@
+From f67a877d583eba5472003f0ea4df3f7420d70734 Mon Sep 17 00:00:00 2001
+From: Gregor Riepl <onitake@gmail.com>
+Date: Mon, 27 Nov 2023 13:01:55 +0100
+Subject: [PATCH] Make initializers explicit to avoid ambiguous wxArrayString
+ overloads
+
+--- a/src/slic3r/GUI/PhysicalPrinterDialog.cpp
++++ b/src/slic3r/GUI/PhysicalPrinterDialog.cpp
+@@ -606,7 +606,7 @@ void PhysicalPrinterDialog::build_printhost_settings(ConfigOptionsGroup* m_optgr
+ // Always fill in the "printhost_port" combo box from the config and select it.
+ {
+ Choice* choice = dynamic_cast<Choice*>(m_optgroup->get_field("printhost_port"));
+- choice->set_values({ m_config->opt_string("printhost_port") });
++ choice->set_values(std::vector<std::string>({ m_config->opt_string("printhost_port") }));
+ choice->set_selection();
+ }
+
+--- a/src/slic3r/GUI/Plater.cpp
++++ b/src/slic3r/GUI/Plater.cpp
+@@ -4048,7 +4048,7 @@ void Plater::load_project(const wxString& filename)
+
+ p->reset();
+
+- if (! load_files({ into_path(filename) }).empty()) {
++ if (! load_files(std::vector<boost::filesystem::path>({ into_path(filename) })).empty()) {
+ // At least one file was loaded.
+ p->set_project_filename(filename);
+ // Save the names of active presets and project specific config into ProjectDirtyStateManager.
diff --git a/media-gfx/prusaslicer/prusaslicer-2.8.0.ebuild b/media-gfx/prusaslicer/prusaslicer-2.8.0.ebuild
index ed23b287f530..b9b50e84c4d5 100644
--- a/media-gfx/prusaslicer/prusaslicer-2.8.0.ebuild
+++ b/media-gfx/prusaslicer/prusaslicer-2.8.0.ebuild
@@ -63,6 +63,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.6.0-dont-force-link-to-wayland-and-x11.patch"
"${FILESDIR}/${PN}-2.8.0-missing-includes.patch"
"${FILESDIR}/${PN}-2.8.0-fixed-linking.patch"
+ "${FILESDIR}/${PN}-2.8.0-wxwidgets-3.2.4.patch"
)
src_prepare() {
diff --git a/media-gfx/prusaslicer/prusaslicer-9999.ebuild b/media-gfx/prusaslicer/prusaslicer-9999.ebuild
index e1c44c35352b..4ecd39373186 100644
--- a/media-gfx/prusaslicer/prusaslicer-9999.ebuild
+++ b/media-gfx/prusaslicer/prusaslicer-9999.ebuild
@@ -62,6 +62,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-2.6.0-dont-force-link-to-wayland-and-x11.patch"
"${FILESDIR}/${PN}-2.8.0-missing-includes.patch"
+ "${FILESDIR}/${PN}-2.8.0-wxwidgets-3.2.4.patch"
"${FILESDIR}/${PN}-2.8.1-fixed-linking.patch"
"${FILESDIR}/${PN}-2.8.1-eigen3.patch"
"${FILESDIR}/${PN}-2.8.1-cgal.patch"