summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/fidlib/fidlib-0.9.10-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/fidlib/fidlib-0.9.10-r1.ebuild')
-rw-r--r--media-libs/fidlib/fidlib-0.9.10-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/fidlib/fidlib-0.9.10-r1.ebuild b/media-libs/fidlib/fidlib-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..a76d0f732617
--- /dev/null
+++ b/media-libs/fidlib/fidlib-0.9.10-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic eutils multilib
+
+DESCRIPTION="Run-time filter design and execution library"
+HOMEPAGE="http://uazu.net/fidlib/"
+SRC_URI="http://uazu.net/fidlib/${P}.tgz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-extern.patch
+
+ # Avoid ICE under gcc-4.6, fixed in 4.6.3
+ if [[ $(gcc-version) == "4.6" && $(gcc-micro-version) -le 2 ]] ; then
+ replace-flags -O? -O0
+ fi
+}
+
+src_compile() {
+ # build library
+ doecho $(tc-getCC) ${CFLAGS} -DT_LINUX ${LDFLAGS} -Wl,-soname,libfidlib.so.${PV:0:1} \
+ -fPIC -shared fidlib.c -lm -o libfidlib.so.${PV:0:1}
+
+ # build command-line tool
+ doecho $(tc-getCC) ${CFLAGS} ${LDFLAGS} firun.c -lm ./libfidlib.so.${PV:0:1} -o firun
+}
+
+src_install() {
+ dobin firun
+ dolib.so libfidlib.so.${PV:0:1}
+ dosym libfidlib.so.${PV:0:1} /usr/$(get_libdir)/libfidlib.so
+
+ insinto /usr/include/fidlib
+ doins fidlib.h
+
+ dodoc NEWS README fidlib.txt firun.txt
+}