summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-08-18 16:06:27 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-08-18 16:09:46 +0200
commit2d94f0f130f74c487a83be6e50bd75c4f6bbb9d3 (patch)
tree2d13c9f1183d8e6bd678261236e2b01426fe70f8 /media-libs/harfbuzz
parentmedia-video/unifi-video: fix EAPI=8 fallout (diff)
downloadgentoo-2d94f0f130f74c487a83be6e50bd75c4f6bbb9d3.tar.gz
gentoo-2d94f0f130f74c487a83be6e50bd75c4f6bbb9d3.tar.bz2
gentoo-2d94f0f130f74c487a83be6e50bd75c4f6bbb9d3.zip
media-libs/harfbuzz: Bump to version 2.9.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-2.9.0.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index 0d69639fd218..a4644d38fe45 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -1,2 +1,3 @@
DIST harfbuzz-2.8.1.tar.gz 17939717 BLAKE2B 4e6eeb0beb45e88386d994eb219479a2ed68bd1b78af3becb4ef1c89152e21924319b415e194f57c7aa4acf8031ab4ae35725b873f36b6f816aaa33a7bbb86d9 SHA512 16e43b9182d3ebd2394c2c0e0df815ca9e715d55dc7e46de4eafcde49ddf59cccae69a5340e05c8aa2ee6bc2ba46d1cffae8252d1b2a004ffe9d70c62628cf73
DIST harfbuzz-2.8.2.tar.gz 18506485 BLAKE2B 39a43d643339a5bc27d886e418695d2864ad7b9094dc508f5ccf52bf635b340adb7ec6958a15349e0b2580444ec98c5850e4022f708287fbe44cb7ea90065881 SHA512 51eee8c8fa6f839512e0dfc5c80ae8ed1e09d747d0ffc6736e5a1cbf86de956322f23e6ea25a90985e2317e98229a133e208da2a7b5177d65894cc64706ee8d4
+DIST harfbuzz-2.9.0.tar.gz 18794661 BLAKE2B f11f8e744e8d344b340006cc2f3a4f90e32ca62a7f6d737fa339b646ebfa95a92b4ce1bc558fb814ecc95f8b04135c2ae2824d2c31d76411f6e0c1223691c393 SHA512 6c9f32b91d261b3d3a3b5110300ecff750958f889d23b23e407817526efaad9dfd94c4979414f299f9d23a7313e24aaad0da48d02d374b873583d5419c420803
diff --git a/media-libs/harfbuzz/harfbuzz-2.9.0.ebuild b/media-libs/harfbuzz/harfbuzz-2.9.0.ebuild
new file mode 100644
index 000000000000..f47e641c6eed
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-2.9.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit flag-o-matic meson-multilib python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/harfbuzz/harfbuzz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+
+IUSE="+cairo debug doc experimental +glib +graphite icu +introspection static-libs test +truetype"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-util/glib-utils )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ sed -i \
+ -e '/tests\/macos\.tests/d' \
+ test/shape/data/in-house/Makefile.sources \
+ || die # bug 726120
+
+ # bug 618772
+ append-cxxflags -std=c++14
+
+ # bug 790359
+ filter-flags -fexceptions -fthreadsafe-statics
+
+ # bug 762415
+ local pyscript
+ for pyscript in $(find -type f -name "*.py") ; do
+ python_fix_shebang -q "${pyscript}"
+ done
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ local emesonargs=(
+ -Dcoretext="disabled"
+ -Dfontconfig="disabled" #609300
+
+ $(meson_feature glib)
+ $(meson_feature graphite)
+ $(meson_feature icu)
+ $(meson_feature introspection gobject)
+ $(meson_feature test tests)
+ $(meson_feature truetype freetype)
+
+ $(meson_native_use_feature cairo)
+ $(meson_native_use_feature doc docs)
+ $(meson_native_use_feature introspection)
+
+ $(meson_use experimental experimental_api)
+ $(meson_use static-libs static)
+ )
+ meson_src_configure
+}