summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-07 20:35:12 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-07 20:58:51 +0100
commit4483a7e702cf80e91abb7b2aba3814f160d43c58 (patch)
treecb2349b3e76a87af1e6549c635e15505cf5c8d11 /media-libs/jasper
parentmedia-libs/jasper: Version bump to 2.0.5 (diff)
downloadgentoo-4483a7e702cf80e91abb7b2aba3814f160d43c58.tar.gz
gentoo-4483a7e702cf80e91abb7b2aba3814f160d43c58.tar.bz2
gentoo-4483a7e702cf80e91abb7b2aba3814f160d43c58.zip
media-libs/jasper: Update live ebuild
Package-Manager: portage-2.3.3
Diffstat (limited to 'media-libs/jasper')
-rw-r--r--media-libs/jasper/jasper-9999.ebuild46
1 files changed, 23 insertions, 23 deletions
diff --git a/media-libs/jasper/jasper-9999.ebuild b/media-libs/jasper/jasper-9999.ebuild
index 7c007cdc115f..3ce95c921b70 100644
--- a/media-libs/jasper/jasper-9999.ebuild
+++ b/media-libs/jasper/jasper-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit autotools multilib-minimal
+inherit cmake-multilib
DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
HOMEPAGE="http://www.ece.uvic.ca/~mdadams/jasper/"
@@ -24,36 +24,36 @@ fi
: ${JASPER_MEM_LIMIT:=134217728}
LICENSE="JasPer2.0"
-SLOT="0/1"
-IUSE="jpeg opengl static-libs"
+SLOT="0"
+IUSE="doc jpeg opengl"
RDEPEND="
jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
opengl? (
>=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
>=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
- virtual/glu
+ virtual/glu[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXmu[${MULTILIB_USEDEP}]
)"
DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_prepare() {
- default
- eautoreconf
-}
+ doc? ( app-doc/doxygen )"
multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable jpeg libjpeg) \
- $(use_enable opengl) \
- $(use_enable static-libs static) \
- --enable-memory-limit="${JASPER_MEM_LIMIT}"
-}
-
-multilib_src_install_all() {
- einstalldocs
- dodoc -r doc/.
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
+ local mycmakeargs=(
+ -DJAS_ENABLE_AUTOMATIC_DEPENDENCIES=OFF
+ -DALLOW_IN_SOURCE_BUILD=OFF
+ -DBASH_PROGRAM="${EPREFIX}"/bin/bash
+ -DJAS_ENABLE_ASAN=OFF
+ -DJAS_ENABLE_LIBJPEG=$(usex jpeg)
+ -DJAS_ENABLE_LSAN=OFF
+ -DJAS_ENABLE_MSAN=OFF
+ -DJAS_ENABLE_OPENGL=$(usex opengl)
+ -DJAS_ENABLE_SHARED=ON
+ -DJAS_ENABLE_STRICT=ON
+ -DJAS_ENABLE_USAN=OFF
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
+ )
+ cmake-utils_src_configure
}