summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-05-13 16:58:12 +0200
committerMatt Turner <mattst88@gentoo.org>2024-06-05 16:01:31 -0400
commitcff513ed677d5d909999db004be46c7830c3e3d1 (patch)
tree974d0b187d792bb30bcb5d1ca95a6475a174e834 /media-libs/mesa
parentmedia-libs/mesa: update USE=xa dependencies (diff)
downloadgentoo-cff513ed677d5d909999db004be46c7830c3e3d1.tar.gz
gentoo-cff513ed677d5d909999db004be46c7830c3e3d1.tar.bz2
gentoo-cff513ed677d5d909999db004be46c7830c3e3d1.zip
media-libs/mesa: update USE=vulkan drivers
Update vulkan-drivers to match meson.build. - add lavapipe - add nouveau - add panfrost - add virgl https://gitlab.freedesktop.org/mesa/mesa/-/blob/mesa-24.1.0-r1/meson.build?ref_type=tags#L234 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-24.1.0-r1.ebuild15
-rw-r--r--media-libs/mesa/mesa-9999.ebuild15
2 files changed, 22 insertions, 8 deletions
diff --git a/media-libs/mesa/mesa-24.1.0-r1.ebuild b/media-libs/mesa/mesa-24.1.0-r1.ebuild
index 193388098fd4..f459b1ddea5a 100644
--- a/media-libs/mesa/mesa-24.1.0-r1.ebuild
+++ b/media-libs/mesa/mesa-24.1.0-r1.ebuild
@@ -198,10 +198,14 @@ pkg_pretend() {
if ! use video_cards_d3d12 &&
! use video_cards_freedreno &&
! use video_cards_intel &&
+ ! use video_cards_lavapipe &&
+ ! use video_cards_nouveau &&
+ ! use video_cards_nvk &&
+ ! use video_cards_panfrost &&
! use video_cards_radeonsi &&
! use video_cards_v3d &&
- ! use video_cards_nvk; then
- ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain d3d12, freedreno, intel, radeonsi, v3d, or nvk"
+ ! use video_cards_virgl; then
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain d3d12, freedreno, intel, lavapipe, nouveau, nvk, panfrost, radeonsi, v3d, or virgl"
fi
fi
@@ -397,12 +401,15 @@ multilib_src_configure() {
fi
if use vulkan; then
- vulkan_enable video_cards_lavapipe swrast
+ vulkan_enable video_cards_d3d12 microsoft-experimental
vulkan_enable video_cards_freedreno freedreno
vulkan_enable video_cards_intel intel intel_hasvk
- vulkan_enable video_cards_d3d12 microsoft-experimental
+ vulkan_enable video_cards_lavapipe swrast
+ vulkan_enable video_cards_panfrost panfrost
vulkan_enable video_cards_radeonsi amd
vulkan_enable video_cards_v3d broadcom
+ vulkan_enable video_cards_vc4 broadcom
+ vulkan_enable video_cards_virgl virtio
if use video_cards_nvk; then
vulkan_enable video_cards_nvk nouveau
if ! multilib_is_native_abi; then
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 2ecab1a2a381..fefb310b0034 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -195,10 +195,14 @@ pkg_pretend() {
if ! use video_cards_d3d12 &&
! use video_cards_freedreno &&
! use video_cards_intel &&
+ ! use video_cards_lavapipe &&
+ ! use video_cards_nouveau &&
+ ! use video_cards_nvk &&
+ ! use video_cards_panfrost &&
! use video_cards_radeonsi &&
! use video_cards_v3d &&
- ! use video_cards_nvk; then
- ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain d3d12, freedreno, intel, radeonsi, v3d, or nvk"
+ ! use video_cards_virgl; then
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain d3d12, freedreno, intel, lavapipe, nouveau, nvk, panfrost, radeonsi, v3d, or virgl"
fi
fi
@@ -394,12 +398,15 @@ multilib_src_configure() {
fi
if use vulkan; then
- vulkan_enable video_cards_lavapipe swrast
+ vulkan_enable video_cards_d3d12 microsoft-experimental
vulkan_enable video_cards_freedreno freedreno
vulkan_enable video_cards_intel intel intel_hasvk
- vulkan_enable video_cards_d3d12 microsoft-experimental
+ vulkan_enable video_cards_lavapipe swrast
+ vulkan_enable video_cards_panfrost panfrost
vulkan_enable video_cards_radeonsi amd
vulkan_enable video_cards_v3d broadcom
+ vulkan_enable video_cards_vc4 broadcom
+ vulkan_enable video_cards_virgl virtio
if use video_cards_nvk; then
vulkan_enable video_cards_nvk nouveau
if ! multilib_is_native_abi; then