summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-29 01:03:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-29 01:28:24 -0400
commit654f46358be674b8231d1b77b69b32000650a568 (patch)
treeb42aea8628a412ca39868d842d2e2a9bf2d718c8 /media-libs/volpack/volpack-1.0_p7-r2.ebuild
parentwww-apps/gitea: Stabilize 1.17.2 amd64, #873373 (diff)
downloadgentoo-654f46358be674b8231d1b77b69b32000650a568.tar.gz
gentoo-654f46358be674b8231d1b77b69b32000650a568.tar.bz2
gentoo-654f46358be674b8231d1b77b69b32000650a568.zip
media-libs/volpack: EAPI7->8, use https, drop static-libs
Also install examples before html docs so they don't end up in html/examples through the docinto. Unsure if this package still has uses, no revdeps (overlays?). Assuming static-libs are at least not needed. Closes: https://bugs.gentoo.org/847517 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-libs/volpack/volpack-1.0_p7-r2.ebuild')
-rw-r--r--media-libs/volpack/volpack-1.0_p7-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/volpack/volpack-1.0_p7-r2.ebuild b/media-libs/volpack/volpack-1.0_p7-r2.ebuild
new file mode 100644
index 000000000000..52cab1b988bf
--- /dev/null
+++ b/media-libs/volpack/volpack-1.0_p7-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-${PV/_p/c}"
+
+DESCRIPTION="Volume rendering library"
+HOMEPAGE="https://amide.sourceforge.net/packages.html"
+SRC_URI="mirror://sourceforge/amide/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+BDEPEND="sys-devel/m4"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ if use doc; then
+ dodoc doc/*.pdf
+
+ docinto html
+ dodoc doc/*.html
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}