summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 14:05:30 -0400
committerSam James <sam@gentoo.org>2024-03-18 05:29:45 +0000
commit0ebc968dfade4f0e0af7e47ad49c9b4f5cc67d3d (patch)
tree792d8eaebae035b0514840ca610a5f5276014fe0 /media-libs
parentsci-electronics/kicad: fix UnstatedIuse for USE=test (diff)
downloadgentoo-0ebc968dfade4f0e0af7e47ad49c9b4f5cc67d3d.tar.gz
gentoo-0ebc968dfade4f0e0af7e47ad49c9b4f5cc67d3d.tar.bz2
gentoo-0ebc968dfade4f0e0af7e47ad49c9b4f5cc67d3d.zip
media-libs/zmusic: mark as LTO-unsafe
It's not actually LTO unsafe. Its bundled adlmidi dependency is. Unfortunately, this package uses bundled dependencies and it's only gotten worse in later upstream releases. Issue still present in upstream git and in the libadlmidi source as well. Not currently up to figuring out how to patch the heck out of this to devendor it, given upstream doesn't provide options for it. Bug: https://github.com/ZDoom/ZMusic/issues/56 Closes: https://bugs.gentoo.org/860117 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/zmusic/zmusic-1.1.4.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/zmusic/zmusic-1.1.4.ebuild b/media-libs/zmusic/zmusic-1.1.4.ebuild
index e3c6a68b03d6..4b2775a4fc4f 100644
--- a/media-libs/zmusic/zmusic-1.1.4.ebuild
+++ b/media-libs/zmusic/zmusic-1.1.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake
+inherit cmake flag-o-matic
MY_PN="ZMusic"
DESCRIPTION="GZDoom's music system as a standalone library"
@@ -35,6 +35,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/860117
+ # https://github.com/ZDoom/ZMusic/issues/56
+ filter-lto
+
local mycmakeargs=(
-DFORCE_INTERNAL_ZLIB=OFF
-DFORCE_INTERNAL_GME=ON