summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-03 21:59:21 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-03 21:59:39 +0200
commit4707f66ad0c079c17adee13826193ac2430ed9ab (patch)
tree576e0dff2aafd76acf53a5cc109a25058e97a91f /media-libs
parentnet-misc/gnome-remote-desktop: Drop old versions (diff)
downloadgentoo-4707f66ad0c079c17adee13826193ac2430ed9ab.tar.gz
gentoo-4707f66ad0c079c17adee13826193ac2430ed9ab.tar.bz2
gentoo-4707f66ad0c079c17adee13826193ac2430ed9ab.zip
media-libs/libopenaptx: bump to v0.2.1
License changed to GPL 3+ [Link 1]. Link 1: https://github.com/pali/libopenaptx/commit/811bc18586d634042618d633727ac0281d4170b8 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libopenaptx/Manifest1
-rw-r--r--media-libs/libopenaptx/libopenaptx-0.2.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/libopenaptx/Manifest b/media-libs/libopenaptx/Manifest
index 7271834f99f6..c1a88d38acb8 100644
--- a/media-libs/libopenaptx/Manifest
+++ b/media-libs/libopenaptx/Manifest
@@ -1 +1,2 @@
DIST libopenaptx-0.2.0.tar.gz 27797 BLAKE2B b178a9aaf78796c9219d9e7066ff985ce9f5dd86a6926ae22e373f2822090ad313efe04d5cf607940f1042bd27ddf5484d7e8298dfff91a8ae5596cec7ad5fa9 SHA512 d57e5084b398eec2ad49c9893baa496651c139abfb95692c834a4691bc4bb951d0b1afdd499a8b67c84b873407b584965d3a045d8ef3d9e62b3ccf45de22809a
+DIST libopenaptx-0.2.1.tar.gz 31575 BLAKE2B 531a1b4e8f4a711bf1b36dfea2424b23821dd4f0b50cc367e1298fc7a41f32ec494fdb25907173d1e2685bd0af74d3ebe5a7a3f221f2e57e92bd6d6e2b8b80c8 SHA512 7c7f515585ed41cd276cd3141037ce21e3ebdb713dc932bcdb33320d9910c734bc81e581e2c09b3399b3516c789e5da7128fdab5ab6b5e4f42a86b6ac6d3f28c
diff --git a/media-libs/libopenaptx/libopenaptx-0.2.1.ebuild b/media-libs/libopenaptx/libopenaptx-0.2.1.ebuild
new file mode 100644
index 000000000000..534df52cba0c
--- /dev/null
+++ b/media-libs/libopenaptx/libopenaptx-0.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Reverse-engineered aptX and aptX HD library"
+HOMEPAGE="https://github.com/pali/libopenaptx"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pali/${PN}"
+else
+ SRC_URI="https://github.com/pali/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+IUSE="cpu_flags_x86_avx2"
+
+src_compile() {
+ tc-export CC AR
+
+ use cpu_flags_x86_avx2 && append-cflags "-mavx2"
+
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ LIBDIR=$(get_libdir) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ all
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ DESTDIR="${D}" \
+ LIBDIR="$(get_libdir)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ install
+
+ find "${ED}" -name '*.a' -delete || die
+}