summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-12 12:28:43 -0500
committerMatt Turner <mattst88@gentoo.org>2022-11-12 12:28:43 -0500
commitb2bb3770f9ff7364a4cd05c850dfa121d109bc72 (patch)
tree891de818ada0bde7bc2c6c8e6c11de6c535367a6 /media-libs
parentmedia-libs/libzen: Drop old versions (diff)
downloadgentoo-b2bb3770f9ff7364a4cd05c850dfa121d109bc72.tar.gz
gentoo-b2bb3770f9ff7364a4cd05c850dfa121d109bc72.tar.bz2
gentoo-b2bb3770f9ff7364a4cd05c850dfa121d109bc72.zip
media-libs/openexr: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openexr/Manifest1
-rw-r--r--media-libs/openexr/openexr-2.5.8.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/media-libs/openexr/Manifest b/media-libs/openexr/Manifest
index bd6854bc0ea7..3a13467779b7 100644
--- a/media-libs/openexr/Manifest
+++ b/media-libs/openexr/Manifest
@@ -1,2 +1 @@
-DIST openexr-2.5.8.tar.gz 27539605 BLAKE2B b54b72aa82c947fd7f252bf4d15b2727be2da7cdd257a9d96c6c2a3c892438ff850177549144e492617bfe5d260ddd14d21eac70a55f124784bbdf5f7077d1e9 SHA512 5b1ad99cfa639892292109a26c084868b3fe0acf572dd69750e951cec2127d63c78309241de92b0052f0abe50d86f2518e3185194121010db5f826d217e37f4f
DIST openexr-3.1.5.tar.gz 20327926 BLAKE2B 77ece3c62b34292d4714873149a5a54a47fe811e96f992f1082e7dca99ad7717649f937c2dd7b18011c4201f15056526fc4b706c4d2f1b7fa593b9f1ed6314bd SHA512 01ef16eacd2dde83c67b81522bae87f47ba272a41ce7d4e35d865dbdcaa03093e7ac504b95d2c1b3a19535f2364a4f937b0e0570c74243bb1c6e021fce7b620c
diff --git a/media-libs/openexr/openexr-2.5.8.ebuild b/media-libs/openexr/openexr-2.5.8.ebuild
deleted file mode 100644
index fbe8a897d4ff..000000000000
--- a/media-libs/openexr/openexr-2.5.8.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
-HOMEPAGE="https://www.openexr.com/"
-SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P}/OpenEXR"
-
-LICENSE="BSD"
-SLOT="0/25" # based on SONAME
-# -ppc -sparc because broken on big endian, bug #818424
-KEYWORDS="amd64 ~arm arm64 ~ia64 -ppc ~ppc64 ~riscv -sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="cpu_flags_x86_avx doc examples static-libs utils test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ~media-libs/ilmbase-${PV}:=[static-libs?,${MULTILIB_USEDEP}]
- sys-libs/zlib[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( PATENTS README.md )
-
-src_prepare() {
- # Fix path for testsuite
- sed -i -e "s:/var/tmp/:${T}:" "${S}"/IlmImfTest/tmpDir.h || die "failed to set temp path for tests"
-
- # disable failing tests on various arches
- if use test; then
- if use abi_x86_32; then
- eapply "${FILESDIR}/${PN}-2.5.2-0001-IlmImfTest-main.cpp-disable-tests.patch"
- fi
-
- # Technically this doesn't disable anything, it just gives this test time to complete.
- # Could probably be applied unconditionally but will leave this to the maintainers.
- if use riscv; then
- eapply "${FILESDIR}/${PN}-2.5.7-0002-increase-IlmImfTest-timeout.patch"
- fi
- fi
-
- multilib_foreach_abi cmake_src_prepare
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test)
- -DINSTALL_OPENEXR_DOCS=$(usex doc)
- -DINSTALL_OPENEXR_EXAMPLES=$(usex examples)
- -DOPENEXR_BUILD_BOTH_STATIC_SHARED=$(usex static-libs)
- -DOPENEXR_BUILD_UTILS=$(usex utils)
- -DOPENEXR_INSTALL_PKG_CONFIG=ON
- -DOPENEXR_USE_CLANG_TIDY=OFF # don't look for clang-tidy
- )
-
- cmake_src_configure
-}
-
-multilib_src_install_all() {
- if use doc; then
- DOCS+=( doc/*.pdf )
- fi
- einstalldocs
-
- use examples && docompress -x /usr/share/doc/${PF}/examples
-}