summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-09 05:07:52 +0000
committerSam James <sam@gentoo.org>2024-12-09 05:15:43 +0000
commitbde7956f7d299e3809305e3c10259cef518a6020 (patch)
treedd342fc4b6ee1e85083ca9064c7b20caa2e5e142 /media-libs
parentsys-fs/udisks: fix build with slibtool (diff)
downloadgentoo-bde7956f7d299e3809305e3c10259cef518a6020.tar.gz
gentoo-bde7956f7d299e3809305e3c10259cef518a6020.tar.bz2
gentoo-bde7956f7d299e3809305e3c10259cef518a6020.zip
media-libs/xvid: drop 1.3.7, 1.3.7-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xvid/metadata.xml3
-rw-r--r--media-libs/xvid/xvid-1.3.7-r1.ebuild69
-rw-r--r--media-libs/xvid/xvid-1.3.7.ebuild66
3 files changed, 0 insertions, 138 deletions
diff --git a/media-libs/xvid/metadata.xml b/media-libs/xvid/metadata.xml
index a12998a66dd6..c7e80df04d05 100644
--- a/media-libs/xvid/metadata.xml
+++ b/media-libs/xvid/metadata.xml
@@ -4,7 +4,4 @@
<maintainer type="project">
<email>media-video@gentoo.org</email>
</maintainer>
- <use>
- <flag name="pic">disable optimized assembly code that is not PIC friendly</flag>
- </use>
</pkgmetadata>
diff --git a/media-libs/xvid/xvid-1.3.7-r1.ebuild b/media-libs/xvid/xvid-1.3.7-r1.ebuild
deleted file mode 100644
index ffd1a7e39754..000000000000
--- a/media-libs/xvid/xvid-1.3.7-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PN="${PN}core"
-MY_P="${MY_PN}-${PV}"
-inherit flag-o-matic multilib-minimal
-
-DESCRIPTION="High performance/quality MPEG-4 video de-/encoding solution"
-HOMEPAGE="https://labs.xvid.com/source/ https://www.xvid.org/"
-SRC_URI="https://downloads.xvid.com/downloads/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="examples pic"
-
-NASM=">=dev-lang/nasm-2"
-YASM=">=dev-lang/yasm-1"
-
-BDEPEND="sys-apps/grep"
-DEPEND="amd64? ( || ( ${YASM} ${NASM} ) )
- x86? ( || ( ${YASM} ${NASM} ) )
- x64-macos? ( ${NASM} )"
-
-S="${WORKDIR}/${MY_PN}/build/generic"
-
-src_prepare() {
- default
-
- # make build verbose
- sed \
- -e 's/@$(CC)/$(CC)/' \
- -e 's/@$(AS)/$(AS)/' \
- -e 's/@$(RM)/$(RM)/' \
- -e 's/@$(INSTALL)/$(INSTALL)/' \
- -e 's/@cd/cd/' \
- -e '/\$(libdir)\/\$(STATIC_LIB)/d' \
- -e 's/\$(BUILD_DIR)\/\$(STATIC_LIB)//g' \
- -e 's/info \$(STATIC_LIB)/info/g' \
- -i Makefile || die
- # Since only the build system is in $S, this will only copy it but not the
- # entire sources.
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- use sparc && append-cflags -mno-vis #357149
-
- local myconf=(
- --enable-pthread
- )
-
- if use pic || [[ ${ABI} == "x32" ]] ; then #421841
- myconf+=( --disable-assembly )
- fi
-
- econf "${myconf[@]}"
-}
-
-multilib_src_install_all() {
- dodoc "${S}"/../../{AUTHORS,ChangeLog*,CodingStyle,README,TODO}
-
- if use examples; then
- insinto /usr/share/${PN}
- doins -r "${S}"/../../examples
- fi
-}
diff --git a/media-libs/xvid/xvid-1.3.7.ebuild b/media-libs/xvid/xvid-1.3.7.ebuild
deleted file mode 100644
index b5e83cf121c2..000000000000
--- a/media-libs/xvid/xvid-1.3.7.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="${PN}core"
-MY_P="${MY_PN}-${PV}"
-inherit flag-o-matic multilib-minimal
-
-DESCRIPTION="High performance/quality MPEG-4 video de-/encoding solution"
-HOMEPAGE="https://labs.xvid.com/source/ https://www.xvid.org/"
-SRC_URI="https://downloads.xvid.com/downloads/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="examples pic +threads"
-
-NASM=">=dev-lang/nasm-2"
-YASM=">=dev-lang/yasm-1"
-
-BDEPEND="sys-apps/grep"
-DEPEND="amd64? ( || ( ${YASM} ${NASM} ) )
- x86? ( || ( ${YASM} ${NASM} ) )
- x64-macos? ( ${NASM} )"
-
-S="${WORKDIR}/${MY_PN}/build/generic"
-
-src_prepare() {
- default
-
- # make build verbose
- sed \
- -e 's/@$(CC)/$(CC)/' \
- -e 's/@$(AS)/$(AS)/' \
- -e 's/@$(RM)/$(RM)/' \
- -e 's/@$(INSTALL)/$(INSTALL)/' \
- -e 's/@cd/cd/' \
- -e '/\$(libdir)\/\$(STATIC_LIB)/d' \
- -e 's/\$(BUILD_DIR)\/\$(STATIC_LIB)//g' \
- -e 's/info \$(STATIC_LIB)/info/g' \
- -i Makefile || die
- # Since only the build system is in $S, this will only copy it but not the
- # entire sources.
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- use sparc && append-cflags -mno-vis #357149
-
- local myconf=( $(use_enable threads pthread) )
- if use pic || [[ ${ABI} == "x32" ]] ; then #421841
- myconf+=( --disable-assembly )
- fi
-
- econf "${myconf[@]}"
-}
-
-multilib_src_install_all() {
- dodoc "${S}"/../../{AUTHORS,ChangeLog*,CodingStyle,README,TODO}
-
- if use examples; then
- insinto /usr/share/${PN}
- doins -r "${S}"/../../examples
- fi
-}