summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-03-17 21:53:34 +0300
committerSam James <sam@gentoo.org>2022-03-18 00:31:41 +0000
commit3bbfabcbf72ad21914c56e510158935e3bafbe89 (patch)
treeb10a0a20b4e664ca657361fab08283bc6926fc77 /media-plugins/gst-plugins-hls/gst-plugins-hls-1.18.6.ebuild
parentmedia-sound/pulseaudio: Add USE=aptx dependency on gst-plugins-openaptx (diff)
downloadgentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.tar.gz
gentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.tar.bz2
gentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.zip
media-libs/gstreamer: Version bump, 1.18.6
Bug: https://bugs.gentoo.org/835368 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24625 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-hls/gst-plugins-hls-1.18.6.ebuild')
-rw-r--r--media-plugins/gst-plugins-hls/gst-plugins-hls-1.18.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-hls/gst-plugins-hls-1.18.6.ebuild b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.18.6.ebuild
new file mode 100644
index 000000000000..3f087056ca22
--- /dev/null
+++ b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.18.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer-meson
+
+DESCRIPTION="HTTP live streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/nettle:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/gst-plugins-bad-1.18.4-use-system-libs-hls.patch
+)
+
+src_prepare() {
+ default
+ gstreamer_system_library gstadaptivedemux_dep:gstadaptivedemux
+ gstreamer_system_package pbutils_dep:gstreamer-pbutils
+ gstreamer_system_package tag_dep:gstreamer-tag
+ gstreamer_system_package video_dep:gstreamer-video
+ gstreamer_system_library gsturidownloader_dep:gsturidownloader
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dhls-crypto=nettle
+ )
+
+ gstreamer_multilib_src_configure
+}