summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2015-10-25 20:52:59 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2015-10-25 20:54:51 +0100
commit77d98de5041dd7fbd5c2d26e698939c793f8dc88 (patch)
treedefa0cc2e2e00b33c694d6ae44cbefa0f7008aa1 /media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild
parentapp-editors/neovim: Add missing missing eutils eclass (diff)
downloadgentoo-77d98de5041dd7fbd5c2d26e698939c793f8dc88.tar.gz
gentoo-77d98de5041dd7fbd5c2d26e698939c793f8dc88.tar.bz2
gentoo-77d98de5041dd7fbd5c2d26e698939c793f8dc88.zip
bump, compilefix vdr-2.3.1
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild')
-rw-r--r--media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild b/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild
new file mode 100644
index 000000000000..0a48387a201f
--- /dev/null
+++ b/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: systeminfo"
+HOMEPAGE="http://firefly.vdr-developer.org/systeminfo/"
+SRC_URI="http://firefly.vdr-developer.org/systeminfo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.4.7"
+
+RDEPEND="sys-apps/lm_sensors
+ app-admin/hddtemp"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if has_version ">=media-video/vdr-2.3.1"; then
+ epatch "${FILESDIR}/${P}_vdr-2.3.1.patch"
+ fi
+
+ # Makefile correction, .eclass fails in some Makefiles
+ sed -e "s:(VDRINCDIR):(VDRDIR)/include:" -i Makefile
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /usr/share/vdr/systeminfo/
+ insopts -m0755
+ doins "${FILESDIR}"/systeminfo.sh
+}