summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2024-06-18 22:14:39 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 21:09:49 +0200
commit9919763c338544af05336d76ad6cc8df35a8e40b (patch)
tree764e37f43ab5d34000952f03ef925de5dfb9541d /media-plugins
parentmedia-video/vdr-2.2.0-r7: fix clang compile error (diff)
downloadgentoo-9919763c338544af05336d76ad6cc8df35a8e40b.tar.gz
gentoo-9919763c338544af05336d76ad6cc8df35a8e40b.tar.bz2
gentoo-9919763c338544af05336d76ad6cc8df35a8e40b.zip
media-plugins/vdr-calc: add 0.0.1_rc6
Closes: https://bugs.gentoo.org/934202 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/37208 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-calc/files/vdr-calc-0.0.1_rc6_makefile.patch149
-rw-r--r--media-plugins/vdr-calc/vdr-calc-0.0.1_rc6.ebuild23
2 files changed, 172 insertions, 0 deletions
diff --git a/media-plugins/vdr-calc/files/vdr-calc-0.0.1_rc6_makefile.patch b/media-plugins/vdr-calc/files/vdr-calc-0.0.1_rc6_makefile.patch
new file mode 100644
index 000000000000..ac2a0362b32a
--- /dev/null
+++ b/media-plugins/vdr-calc/files/vdr-calc-0.0.1_rc6_makefile.patch
@@ -0,0 +1,149 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,77 +1,115 @@
+ #
+ # Makefile for a Video Disk Recorder plugin
+ #
+-# $Id: Makefile 1.2 2002/12/13 14:54:29 kls Exp $
++# $Id$
+
+ # The official name of this plugin.
+ # This name will be used in the '-P...' option of VDR to load the plugin.
+ # By default the main source file also carries this name.
+-#
++
+ PLUGIN = calc
+
+ ### The version number of this plugin (taken from the main source file):
+
+ VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+-### The C++ compiler and options:
++### The directory environment:
+
+-CXX ?= g++
+-CXXFLAGS ?= -O2 -Wall -Woverloaded-virtual
++# Use package data if installed...otherwise assume we're under the VDR source directory:
++PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell PKG_CONFIG_PATH="$$PKG_CONFIG_PATH:../../.." pkg-config --variable=$(1) vdr))
++LIBDIR = $(call PKGCFG,libdir)
++LOCDIR = $(call PKGCFG,locdir)
++PLGCFG = $(call PKGCFG,plgcfg)
++#
++TMPDIR ?= /tmp
+
+-### The directory environment:
++### The compiler options:
+
+-DVBDIR = ../../../../DVB
+-VDRDIR = ../../..
+-LIBDIR = ../../lib
+-TMPDIR = /tmp
++export CFLAGS = $(call PKGCFG,cflags)
++export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+-### Allow user defined options to overwrite defaults:
++### The version number of VDR's plugin API:
+
+--include $(VDRDIR)/Make.config
++APIVERSION = $(call PKGCFG,apiversion)
+
+-### The version number of VDR (taken from VDR's "config.h"):
++### Allow user defined options to overwrite defaults:
+
+-VDRVERSION = $(shell grep 'define VDRVERSION ' $(VDRDIR)/config.h | awk '{ print $$3 }' | sed -e 's/"//g')
++-include $(PLGCFG)
+
+ ### The name of the distribution archive:
+
+ ARCHIVE = $(PLUGIN)-$(VERSION)
+ PACKAGE = vdr-$(ARCHIVE)
+
++### The name of the shared object file:
++
++SOFILE = libvdr-$(PLUGIN).so
++
+ ### Includes and Defines (add further entries here):
+
+-INCLUDES += -I$(VDRDIR)/include -I$(DVBDIR)/include
++INCLUDES +=
+
+-DEFINES += -D_GNU_SOURCE
+ DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+ ### The object files (add further files here):
+
+ OBJS = $(PLUGIN).o
+
++### The main target:
++
++all: $(SOFILE) i18n
++
+ ### Implicit rules:
+
+ %.o: %.c
+- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) $<
++ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+-# Dependencies:
++### Dependencies:
+
+-MAKEDEP = g++ -MM -MG
++MAKEDEP = $(CXX) -MM -MG
+ DEPFILE = .dependencies
+ $(DEPFILE): Makefile
+- @$(MAKEDEP) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
++ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+ -include $(DEPFILE)
+
++### Internationalization (I18N):
++
++PODIR = po
++I18Npo = $(foreach dir,$(LINGUAS),$(wildcard $(PODIR)/$(dir)*.po))
++I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
++I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
++I18Npot = $(PODIR)/$(PLUGIN).pot
++
++%.mo: %.po
++ msgfmt -c -o $@ $<
++
++$(I18Npot): $(wildcard *.c)
++ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
++
++%.po: $(I18Npot)
++ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
++ @touch $@
++
++$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
++ install -D -m644 $< $@
++
++.PHONY: i18n
++i18n: $(I18Nmo) $(I18Npot)
++
++install-i18n: $(I18Nmsgs)
++
+ ### Targets:
+
+-all: libvdr-$(PLUGIN).so
++$(SOFILE): $(OBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
++
++install-lib: $(SOFILE)
++ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+-libvdr-$(PLUGIN).so: $(OBJS)
+- $(CXX) $(CXXFLAGS) -shared $(OBJS) -o $@
+- @cp $@ $(LIBDIR)/$@.$(VDRVERSION)
++install: install-lib install-i18n
+
+-dist: clean
++dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+@@ -80,4 +118,5 @@
+ @echo Distribution package created as $(PACKAGE).tgz
+
+ clean:
++ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-calc/vdr-calc-0.0.1_rc6.ebuild b/media-plugins/vdr-calc/vdr-calc-0.0.1_rc6.ebuild
new file mode 100644
index 000000000000..14873d671b35
--- /dev/null
+++ b/media-plugins/vdr-calc/vdr-calc-0.0.1_rc6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: OSD Calculator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${PN}-0[1].0.1-rc5.tgz"
+S=${WORKDIR}/${VDRPLUGIN}-0.0.1-rc5
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-video/vdr"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.0.1_rc5-gcc4.diff"
+ "${FILESDIR}/${P}_makefile.patch"
+)