summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-11-21 09:15:55 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-11-21 14:58:55 +0200
commite1a3f548d70d6b5ab3b891c360fc2c88f9d8836c (patch)
tree2096b1cb0c8467bf313d314f3950af0b2cf56dd4 /media-sound/audacious
parentnet-dns/pdns: Require doxygen with dot support, bug #823812 (diff)
downloadgentoo-e1a3f548d70d6b5ab3b891c360fc2c88f9d8836c.tar.gz
gentoo-e1a3f548d70d6b5ab3b891c360fc2c88f9d8836c.tar.bz2
gentoo-e1a3f548d70d6b5ab3b891c360fc2c88f9d8836c.zip
media-sound/audacious: bump to version 4.1
Drop 3.x as it is require GTK+:2 Closes: https://bugs.gentoo.org/775989 Closes: https://bugs.gentoo.org/797835 Bug: https://bugs.gentoo.org/711292 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/Manifest1
-rw-r--r--media-sound/audacious/audacious-4.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/audacious/Manifest b/media-sound/audacious/Manifest
index b73a9242f3d7..6c1aefcf6fc9 100644
--- a/media-sound/audacious/Manifest
+++ b/media-sound/audacious/Manifest
@@ -1,3 +1,4 @@
DIST audacious-3.10.1.tar.bz2 564481 BLAKE2B d1f76f34f0f6fbbe5ba92a95015fa0f3ef6399cc05f69f58474523761b00a4de7b8471660d9cb640487110cc3998df59f21108ff0b4ea72014ad75cd32ad864b SHA512 e88891caaa3897f9b4abf39136e20834aedf1287d0d5eefea392fda89050db8db00c6f363976a68fe250ddbae4e27590f7615916a76370a44ca9235f1fa60b43
DIST audacious-4.0.5.tar.bz2 577422 BLAKE2B a65810baf0f733327a3e37e6efd2af3d35245b1e99936a4cd39d8068e0df06779ab3c08e839e4b3586f70bec2d16a605c62328f863f747247181851ac7c151c2 SHA512 4be7ebeee937f9b29931a28e1d80782b9df8beec70eab3917f5adccd0bf02aa6003a5b8361359b792edac2d2f31a257b853db43d59dd0674e5a3fbec7e7c1e46
+DIST audacious-4.1.tar.bz2 586472 BLAKE2B baed9f47ddca9b6a4668da542483e8ead049126383e8d1b090b29153b698cc83042ce0620bc5c3e78e59c599cb9f1be72b9c8d2e8c3c87f36fae45554a743b24 SHA512 6e603108c245a146c3bb360e99d85e949b25a50a4d97eca6a0519cb457a93e8d73131504ae10f86c34c0e9d98fb5fdf6660accc0bb3bb480332cb674ac27ac9f
DIST gentoo_ice-xmms-0.2.tar.bz2 51839 BLAKE2B d3bf8dbfee675dd588bc0258f1015c76877b6b0a3835813d8e9621d149b924aaa33544d07f7ad44a01c058d41d7480b3908b0773c124af33b6e020c376b13d54 SHA512 e863a8f86073007c47ce8c20739aae4bff22e22a7ddc11556b12ae6ebb68654cec7310fdc9d05f2c47f81cf2591fe601b2eb12a2fd911c0a6118c9f3cc524f05
diff --git a/media-sound/audacious/audacious-4.1.ebuild b/media-sound/audacious/audacious-4.1.ebuild
new file mode 100644
index 000000000000..2f78f555ee74
--- /dev/null
+++ b/media-sound/audacious/audacious-4.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${P/_/-}"
+
+inherit xdg
+
+DESCRIPTION="Lightweight and versatile audio player"
+HOMEPAGE="https://audacious-media-player.org/"
+SRC_URI="https://distfiles.audacious-media-player.org/${MY_P}.tar.bz2"
+SRC_URI+=" mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="nls"
+
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )
+"
+DEPEND="
+ >=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.28
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/pango-1.8.0
+ virtual/freedesktop-icon-theme
+"
+RDEPEND="${DEPEND}"
+PDEPEND="~media-plugins/audacious-plugins-${PV}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ if ! use nls; then
+ sed -e "/SUBDIRS/s/ po//" -i Makefile || die "failed to sed" # bug #512698
+ fi
+}
+
+src_configure() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ local myeconfargs=(
+ --disable-valgrind
+ --disable-gtk
+ --enable-dbus
+ --enable-qt
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins -r "${WORKDIR}"/gentoo_ice/.
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}