summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-12-24 17:08:16 +0200
committerMart Raudsepp <leio@gentoo.org>2017-12-24 17:10:07 +0200
commit045ee08e79d1f700655b981094ad379a1db0f84d (patch)
tree9097d1739086ebac212c2afd236cae03f436d8e4 /media-sound/soundconverter
parentsys-devel/bin86: fix build on x86 musl, bump to EAPI=6 (diff)
downloadgentoo-045ee08e79d1f700655b981094ad379a1db0f84d.tar.gz
gentoo-045ee08e79d1f700655b981094ad379a1db0f84d.tar.bz2
gentoo-045ee08e79d1f700655b981094ad379a1db0f84d.zip
media-sound/soundconverter: bump to 3.0.0-beta1
This version is ported to gstreamer-1.x and modern GNOME introspection based python bindings. Bug: https://bugs.gentoo.org/629186 Bug: https://bugs.gentoo.org/640048 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-sound/soundconverter')
-rw-r--r--media-sound/soundconverter/Manifest1
-rw-r--r--media-sound/soundconverter/soundconverter-3.0.0_beta1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-sound/soundconverter/Manifest b/media-sound/soundconverter/Manifest
index ae63daf683fa..a5bdfc54cc2f 100644
--- a/media-sound/soundconverter/Manifest
+++ b/media-sound/soundconverter/Manifest
@@ -1,2 +1,3 @@
DIST soundconverter-2.1.5.tar.xz 195380 BLAKE2B f168332866ac64c7ccf804af60ad877cb1478253d815a81f9ad92e0d382e3bd0ad78bf3f0ed688482541d15dec964b7387f6a3189c6eeae81a3ea8002c789abc SHA512 6d42bd2cfa200e7af8c69ce94580a4f96bdb0354623207e5d1c3beadee89920363b5b8cee4cdcfa6fcbd036860d50f739b05e34e9a34608fe3d6243876936c6a
DIST soundconverter-2.1.6.tar.xz 195864 BLAKE2B 0be5f5df492742745f56ca3ba90faa134c11f802aefad359e1c03852c87be87e2c57afac811d4f17d2c9303d41e905fb0c9a8c9985c179d216a511183118d369 SHA512 d607d4c260f0b8d810f7251f9bbcd02359984dd2a8bf3340be14602e3392362b9a6bc54a9f0c20f16bfee2f971f784a4093f535307dfb2d6087fb4492511a9ba
+DIST soundconverter-3.0.0-beta1.tar.xz 196916 BLAKE2B 82832a151e030cbd2be129fe7f4dcd92430aadc71b163c3800cc2108f502020561e2c74291cbb25050ed42bd9d71fdfe310f107af84f612711554cf3e32fd07b SHA512 a27a2c7b4156a6d6c682424c5fa64a4dd82537b1dbfa8176fa39fbfc4d139a21b7dd042de80d088333c0aef0042a76940ab8da5d9708b6aac3399b32b7408f09
diff --git a/media-sound/soundconverter/soundconverter-3.0.0_beta1.ebuild b/media-sound/soundconverter/soundconverter-3.0.0_beta1.ebuild
new file mode 100644
index 000000000000..eaeb1703786d
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-3.0.0_beta1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="http://soundconverter.org/"
+MY_PV="${PV/_/-}"
+SRC_URI="https://launchpad.net/${PN}/trunk/${MY_PV}/+download/${PN}-${MY_PV}.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="aac flac libnotify mp3 ogg opus vorbis"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/gobject-introspection:=
+ x11-libs/gtk+:3[introspection]
+ media-libs/gstreamer:1.0[introspection]
+"
+
+# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
+# List in soundconverter/gstreamer.py
+# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gconf:2[introspection]
+ x11-libs/pango[introspection]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ libnotify? ( x11-libs/libnotify[introspection] )
+
+ media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
+ media-plugins/gst-plugins-meta:1.0
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ media-libs/gst-plugins-good:1.0
+ mp3? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ )
+ aac? ( media-plugins/gst-plugins-faac:1.0 )
+ opus? ( media-plugins/gst-plugins-opus:1.0 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+src_prepare() {
+ python_fix_shebang .
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize "${ED%/}"/usr/$(get_libdir)/soundconverter/python
+}