summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2025-01-07 22:08:00 +0000
committerSam James <sam@gentoo.org>2025-01-07 23:41:29 +0000
commit673f78ed3f41918169c1571576eff19102c80599 (patch)
tree963e17ad274ba58e44caf846c4bf02128c4bc093 /media-sound
parentsci-libs/vtk: Stabilize 9.3.1 amd64, #947501 (diff)
downloadgentoo-673f78ed3f41918169c1571576eff19102c80599.tar.gz
gentoo-673f78ed3f41918169c1571576eff19102c80599.tar.bz2
gentoo-673f78ed3f41918169c1571576eff19102c80599.zip
media-sound/clementine: fix build with new dev-libs/protobuf
Depend on it in CMakeLists.txt more correctly Closes: https://bugs.gentoo.org/947632 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/clementine/clementine-1.4.0_rc2-r6.ebuild5
-rw-r--r--media-sound/clementine/files/clementine-1.4.0_rc2-absl2.patch86
2 files changed, 88 insertions, 3 deletions
diff --git a/media-sound/clementine/clementine-1.4.0_rc2-r6.ebuild b/media-sound/clementine/clementine-1.4.0_rc2-r6.ebuild
index cdaced76e890..914852a6f203 100644
--- a/media-sound/clementine/clementine-1.4.0_rc2-r6.ebuild
+++ b/media-sound/clementine/clementine-1.4.0_rc2-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -95,7 +95,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/clementine-1.4.0_rc2-lz.patch"
"${FILESDIR}/clementine-1.4.0_rc2-c17.patch"
- "${FILESDIR}/clementine-1.4.0_rc2-absl.patch"
+ "${FILESDIR}/clementine-1.4.0_rc2-absl2.patch"
"${FILESDIR}/clementine-1.4.0_rc2-projectm-dir.patch"
"${FILESDIR}/clementine-1.4.0_rc2-fix-build-taglib2.patch"
)
@@ -149,7 +149,6 @@ src_configure() {
-DENABLE_UDISKS2="$(usex udisks)"
-DENABLE_WIIMOTEDEV="$(usex wiimote)"
"$(cmake_use_find_package alsa ALSA)"
- -DGENTOO_FIX_ABSL_LIBS="$(test-flags-CCLD -labsl_log_internal_check_op -labsl_log_internal_message)"
)
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
diff --git a/media-sound/clementine/files/clementine-1.4.0_rc2-absl2.patch b/media-sound/clementine/files/clementine-1.4.0_rc2-absl2.patch
new file mode 100644
index 000000000000..f6f9b4532b2b
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.4.0_rc2-absl2.patch
@@ -0,0 +1,86 @@
+Fix build
+
+https://bugs.gentoo.org/912853
+https://bugs.gentoo.org/947632
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 010191b..57163b9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -46,7 +46,7 @@ endif(OPENGL_FOUND)
+ find_package(Boost REQUIRED)
+ find_package(Gettext REQUIRED)
+ find_package(PkgConfig REQUIRED)
+-find_package(Protobuf REQUIRED)
++find_package(protobuf REQUIRED)
+ find_package(FFTW3)
+ find_package(ALSA)
+ if (NOT APPLE)
+diff --git a/ext/libclementine-remote/CMakeLists.txt b/ext/libclementine-remote/CMakeLists.txt
+index 115d1f4..717d76c 100644
+--- a/ext/libclementine-remote/CMakeLists.txt
++++ b/ext/libclementine-remote/CMakeLists.txt
+@@ -6,14 +6,14 @@ set(MESSAGES
+ remotecontrolmessages.proto
+ )
+
+-protobuf_generate_cpp(PROTO_SOURCES PROTO_HEADERS ${MESSAGES})
+-
+ add_library(libclementine-remote STATIC
+- ${PROTO_SOURCES}
++ ${MESSAGES}
+ )
+
++protobuf_generate(TARGET libclementine-remote LANGUAGE cpp)
++
+ target_link_libraries(libclementine-remote
+- ${PROTOBUF_LIBRARY}
+ libclementine-common
++ protobuf::libprotobuf
+ )
+
+diff --git a/ext/libclementine-spotifyblob/CMakeLists.txt b/ext/libclementine-spotifyblob/CMakeLists.txt
+index 7a73b14..072fe60 100644
+--- a/ext/libclementine-spotifyblob/CMakeLists.txt
++++ b/ext/libclementine-spotifyblob/CMakeLists.txt
+@@ -7,12 +7,12 @@ set(MESSAGES
+ spotifymessages.proto
+ )
+
+-protobuf_generate_cpp(PROTO_SOURCES PROTO_HEADERS ${MESSAGES})
+-
+ add_library(clementine-spotifyblob-messages STATIC
+- ${PROTO_SOURCES}
++ ${MESSAGES}
+ )
+
++protobuf_generate(TARGET clementine-spotifyblob-messages LANGUAGE cpp)
++
+ target_link_libraries(clementine-spotifyblob-messages
+ libclementine-common
+ )
+diff --git a/ext/libclementine-tagreader/CMakeLists.txt b/ext/libclementine-tagreader/CMakeLists.txt
+index 8a0a944..fc2d6e6 100644
+--- a/ext/libclementine-tagreader/CMakeLists.txt
++++ b/ext/libclementine-tagreader/CMakeLists.txt
+@@ -28,16 +28,16 @@ optional_source(HAVE_GOOGLE_DRIVE
+
+ qt5_wrap_cpp(MOC ${HEADERS})
+
+-protobuf_generate_cpp(PROTO_SOURCES PROTO_HEADERS ${MESSAGES})
+-
+ add_library(libclementine-tagreader STATIC
+- ${PROTO_SOURCES}
++ ${MESSAGES}
+ ${SOURCES}
+ ${MOC}
+ )
+
++protobuf_generate(TARGET libclementine-tagreader LANGUAGE cpp)
++
+ target_link_libraries(libclementine-tagreader
+- ${PROTOBUF_LIBRARY}
+ libclementine-common
++ protobuf::libprotobuf
+ )
+