summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-01-31 01:31:53 +0200
committerDavid Seifert <soap@gentoo.org>2017-01-31 18:17:59 +0100
commit1e3e746bce040eb291fdb07f788a5e6ac9a16aa9 (patch)
tree757fa0aeb86929dcd42029070544a24070e7e91f /media-video/syncplay/syncplay-1.4.0.ebuild
parentsys-kernel/gentoo-sources: Clean up 4.4.X series (diff)
downloadgentoo-1e3e746bce040eb291fdb07f788a5e6ac9a16aa9.tar.gz
gentoo-1e3e746bce040eb291fdb07f788a5e6ac9a16aa9.tar.bz2
gentoo-1e3e746bce040eb291fdb07f788a5e6ac9a16aa9.zip
media-video/syncplay: version bump to 1.4.0
properly disable GUI when use is unset (prevents error messags) update twisted dep Gentoo-Bug: http://bugs.gentoo.org/605098 Closes: https://github.com/gentoo/gentoo/pull/3234
Diffstat (limited to 'media-video/syncplay/syncplay-1.4.0.ebuild')
-rw-r--r--media-video/syncplay/syncplay-1.4.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-video/syncplay/syncplay-1.4.0.ebuild b/media-video/syncplay/syncplay-1.4.0.ebuild
new file mode 100644
index 000000000000..ad59cf4d8d9a
--- /dev/null
+++ b/media-video/syncplay/syncplay-1.4.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+MY_PV=${PV/_rc/-RC}
+
+DESCRIPTION="Client/server to synchronize media playback"
+HOMEPAGE="http://syncplay.pl"
+SRC_URI="https://github.com/Syncplay/syncplay/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+client +server gui vlc"
+REQUIRED_USE="vlc? ( client )
+ gui? ( client )
+ ${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ || (
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ )
+ gui? ( dev-python/pyside[${PYTHON_USEDEP}] )
+ vlc? ( media-video/vlc[lua] )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ if ! use gui; then
+ sed -i 's/"noGui": False,/"noGui": True,/' \
+ syncplay/ui/ConfigurationGetter.py \
+ || die "Failed to patch ConfigurationGetter.py"
+ fi
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local MY_MAKEOPTS=( DESTDIR="${D}" PREFIX=/usr )
+ use client && \
+ emake "${MY_MAKEOPTS[@]}" VLC_SUPPORT=$(usex vlc true false) install-client
+ use server && \
+ emake "${MY_MAKEOPTS[@]}" install-server
+}
+
+pkg_postinst() {
+ if use client; then
+ einfo "Syncplay supports the following players:"
+ einfo "media-video/mpv, media-video/mplayer2, media-video/vlc"
+ fi
+}