summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-09-30 22:36:12 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-09-30 22:36:52 +0100
commit37c284ea4b16c40de55a06270eeb7a04c09cefba (patch)
tree642b37f1eb2d8129dda7bcc07bc2baa67debf576 /media-video
parentsys-cluster/galera: Stabilize 26.4.20 ppc64, #940534 (diff)
downloadgentoo-37c284ea4b16c40de55a06270eeb7a04c09cefba.tar.gz
gentoo-37c284ea4b16c40de55a06270eeb7a04c09cefba.tar.bz2
gentoo-37c284ea4b16c40de55a06270eeb7a04c09cefba.zip
media-video/makemkv: Version bump to 1.17.8
I tried to migrate this to Qt6 even though upstream doesn't support it yet, but it's not quite trivial. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/makemkv/Manifest2
-rw-r--r--media-video/makemkv/makemkv-1.17.8.ebuild126
2 files changed, 128 insertions, 0 deletions
diff --git a/media-video/makemkv/Manifest b/media-video/makemkv/Manifest
index a81343186078..fa550f132047 100644
--- a/media-video/makemkv/Manifest
+++ b/media-video/makemkv/Manifest
@@ -1,2 +1,4 @@
DIST makemkv-bin-1.17.7.tar.gz 16420879 BLAKE2B adc54191fd445832b9c4805400746e42d1b3261d076299b5e34beb1f13d80bf7bcbd113699f3d28fce5e21bb8f810a40927924b3d9c7250467d1979b1bf4f72b SHA512 2c93dd6e63c5e59415ad8a9a1370f7a1eddda2b643fa4dcde6383abb6065b84a77b03b977bf2ade50bc2d3560bb245ad2e1e79bab21629f7fc5816598738a5d9
+DIST makemkv-bin-1.17.8.tar.gz 17859805 BLAKE2B 0ddbcd50a44a98c118420485c7c8e48a1c03290ac840b22ab8119d5cd6db0743e746ca9cbdd7fd714f49a2a37420645c820477c5c7d7b189763b5a46de342e9d SHA512 033c51a818ccf6537f9709d6d19ce81d89edded7dfa1c24fb080c4c7caf6ae267e18722b39ee27e70752f18d502c819c8c582fc53fbc153013713046ef756c01
DIST makemkv-oss-1.17.7.tar.gz 6618248 BLAKE2B 18652db1d72ea7287e7e38706afc589e6fe8fb1fbf9d4e24770b9a2bfe670a464b2c21b7c543b23d3c6234f40048358d944b123897c4f569beb31faac8ef3eb7 SHA512 e21bc293133d7f999b3ea4258f01f0b88c5a58610da0185d8f74b724d61578211d35d5d44fae1610887e98f3ff36b2f0df33068d8647ad8983020be49adde037
+DIST makemkv-oss-1.17.8.tar.gz 6627058 BLAKE2B 76ffcf0a67c2ee6b05820006ff7926accef7939374b328d709dbbf6c746f010e273f89748a2a3386679b83f2af0b4f3e41f31e8acaf29cdbaeffccaf25b57500 SHA512 4c8d462933138a614afdf4fe5a896400e92299f9ed1882596dd28168c65a654b51ed89c4b0571d60255c2709c0f1dc8b108d4e7d3bbb84842813a661b28f504b
diff --git a/media-video/makemkv/makemkv-1.17.8.ebuild b/media-video/makemkv/makemkv-1.17.8.ebuild
new file mode 100644
index 000000000000..c8dd8c6309b2
--- /dev/null
+++ b/media-video/makemkv/makemkv-1.17.8.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic linux-info xdg
+
+MY_P=makemkv-oss-${PV}
+MY_PB=makemkv-bin-${PV}
+
+DESCRIPTION="Tool for ripping and streaming Blu-ray, HD-DVD and DVD discs"
+HOMEPAGE="http://www.makemkv.com/"
+SRC_URI="http://www.makemkv.com/download/${MY_P}.tar.gz
+ http://www.makemkv.com/download/${MY_PB}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1 MakeMKV-EULA openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+gui +java"
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="usr/bin/makemkvcon usr/bin/mmdtsdec"
+
+DEPEND="
+ dev-libs/expat
+ dev-libs/openssl:0=[-bindist(-)]
+ >=media-video/ffmpeg-1.0.0:0=
+ sys-libs/glibc
+ sys-libs/zlib
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ java? ( >=virtual/jre-1.8 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ gui? ( dev-qt/qtcore:5 )
+"
+
+CONFIG_CHECK="~CHR_DEV_SG"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-path.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use java; then
+ rm -v "${WORKDIR}/${MY_PB}"/src/share/blues.* || die
+ fi
+}
+
+src_configure() {
+ # See bug #439380.
+ replace-flags -O* -Os
+
+ econf \
+ --enable-debug \
+ --disable-noec \
+ $(use_enable gui) \
+ $(use_enable gui qt5)
+}
+
+src_install() {
+ local myarch
+ case "${ARCH}" in
+ arm) myarch=armhf ;;
+ x86) myarch=i386 ;;
+ *) myarch=${ARCH} ;;
+ esac
+
+ default
+
+ # add missing symlinks for QA
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so.0.${PV}
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so.1.${PV}
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so.0.${PV}
+
+ cd "${WORKDIR}"/${MY_PB} || die
+
+ # install prebuilt bin
+ dobin bin/"${myarch}"/makemkvcon
+
+ # additional tool is actually part of makemkvcon
+ dosym makemkvcon /usr/bin/sdftool
+
+ # install profiles and locales
+ insinto /usr/share/MakeMKV
+ doins src/share/*
+
+ # install unofficial man page
+ doman "${FILESDIR}"/makemkvcon.1
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "While MakeMKV is in beta mode, upstream has provided a license"
+ elog "to use if you do not want to purchase one."
+ elog ""
+ elog "See this forum thread for more information, including the key:"
+ elog "https://www.makemkv.com/forum/viewtopic.php?f=5&t=1053"
+ elog ""
+ elog "Note that beta license may have an expiration date and you will"
+ elog "need to check for newer licenses/releases. "
+ elog ""
+ elog "We previously said to copy default.mmcp.xml to ~/.MakeMKV/. This"
+ elog "is no longer necessary and you should delete it from there to"
+ elog "avoid warning messages."
+ elog ""
+ elog "MakeMKV can also act as a drop-in replacement for libaacs and"
+ elog "libbdplus, allowing transparent decryption of a wider range of"
+ elog "titles under players like VLC and mplayer. To enable this, set"
+ elog "the following variables when launching the player:"
+ elog "LIBAACS_PATH=libmmbd LIBBDPLUS_PATH=libmmbd"
+}