summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2015-12-22 17:32:15 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2015-12-28 15:46:50 +0300
commita96ea41546657e3fedfb3d698a0f599d7790fee3 (patch)
tree3b641c38e2eb1c9b469295f79a3f1fcd64eec554 /media-video
parentprofiles/arch/amd64/package.use.mask: typo; add missed '#' (diff)
downloadgentoo-a96ea41546657e3fedfb3d698a0f599d7790fee3.tar.gz
gentoo-a96ea41546657e3fedfb3d698a0f599d7790fee3.tar.bz2
gentoo-a96ea41546657e3fedfb3d698a0f599d7790fee3.zip
media-video/mpv: whitespace change to improve readability
Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/mpv-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index f4f73a502bb7..b079c75eb65d 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -3,6 +3,7 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
PYTHON_REQ_USE='threads(+)'
inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
@@ -159,13 +160,16 @@ src_configure() {
local mywafargs=(
--confdir="${EPREFIX}"/etc/${PN}
--docdir="${EPREFIX}"/usr/share/doc/${PF}
+
$(usex cli '' '--disable-cplayer')
$(use_enable libmpv libmpv-shared)
+
--disable-libmpv-static
--disable-build-date # keep build reproducible
--disable-optimize # do not add '-O2' to CFLAGS
--disable-debug-build # do not add '-g' to CFLAGS
--disable-test # avoid dev-util/cmocka automagic
+
$(use_enable doc-pdf pdf-build)
$(use_enable vf-dlopen vf-dlopen-filters)
$(use_enable cli zsh-comp)
@@ -187,6 +191,7 @@ src_configure() {
$(use_enable lcms lcms2)
--disable-vapoursynth # vapoursynth is not packaged
--disable-vapoursynth-lazy
+
--enable-libavfilter
--enable-libavdevice
$(usex luajit '--lua=luajit' '')