summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/cacti
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/Manifest2
-rw-r--r--net-analyzer/cacti/cacti-0.8.8e.ebuild60
-rw-r--r--net-analyzer/cacti/cacti-0.8.8f.ebuild60
-rw-r--r--net-analyzer/cacti/files/postinstall-en.txt62
-rw-r--r--net-analyzer/cacti/metadata.xml17
5 files changed, 201 insertions, 0 deletions
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
new file mode 100644
index 000000000000..1ab0eaa53a73
--- /dev/null
+++ b/net-analyzer/cacti/Manifest
@@ -0,0 +1,2 @@
+DIST cacti-0.8.8e.tar.gz 2594446 SHA256 43b091957faf03a4b0baacc8c327320394c0843476ea34e3beb1416506ad3f55 SHA512 11eeace353b7bacb2e4f065b1557b6978f0315d372f03f25bbdd210aaa494b70661b24502885bb610d8cf042cdcd68c69ea1a6fd1cb7073af29553116500df0c WHIRLPOOL ea5f29a71504f4e1fb4d8981db84b46fb87842921d8f6f422b8a0c2b127e80b785fca60b3b037036396cf9de456240a573cd446118f03a93f25a2406fe22be40
+DIST cacti-0.8.8f.tar.gz 2594409 SHA256 2ea92407c11bf13302558a5bc9e1f3a57bd14a1d9ded48c505ec495762f76738 SHA512 b712a9f8b7bee632cb4982fed72793ac2f4d70aa042784bbd2fd3923a27901f457393aa95bbd63960187e85fe462c35e88fa3cd93e8537a3a68f94bdbf5d7f2b WHIRLPOOL 58c883780fed833df2501b204a21fc8605e76a7b5ac26ebd13f0bf22f45dda6363be35ada8af2a65f4e7db506d103b6739d73699676c1622e7051eb8a89ad555
diff --git a/net-analyzer/cacti/cacti-0.8.8e.ebuild b/net-analyzer/cacti/cacti-0.8.8e.ebuild
new file mode 100644
index 000000000000..a2bfbc6bd5a4
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.8e.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit depend.php eutils webapp
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ~arm hppa ~ppc ~ppc64 sparc x86"
+IUSE="snmp doc"
+
+need_httpd
+
+RDEPEND="
+ dev-lang/php[cli,mysql,session,sockets,xml]
+ dev-php/adodb
+ net-analyzer/rrdtool[graph]
+ virtual/cron
+ virtual/mysql
+ snmp? ( >=net-analyzer/net-snmp-5.2.0 )
+"
+
+src_prepare() {
+ sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/global.php || die
+
+ rm -rf lib/adodb || die # don't use bundled adodb
+}
+
+src_compile() { :; }
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE README || die
+ dodoc docs/{CHANGELOG,CONTRIB,README,txt/manual.txt}
+ use doc && dohtml -r docs/html/
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/net-analyzer/cacti/cacti-0.8.8f.ebuild b/net-analyzer/cacti/cacti-0.8.8f.ebuild
new file mode 100644
index 000000000000..79420be5fa67
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.8f.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit depend.php eutils webapp
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+need_httpd
+
+RDEPEND="
+ dev-lang/php[cli,mysql,session,sockets,xml]
+ dev-php/adodb
+ net-analyzer/rrdtool[graph]
+ virtual/cron
+ virtual/mysql
+ snmp? ( >=net-analyzer/net-snmp-5.2.0 )
+"
+
+src_prepare() {
+ sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/global.php || die
+
+ rm -rf lib/adodb || die # don't use bundled adodb
+}
+
+src_compile() { :; }
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE README || die
+ dodoc docs/{CHANGELOG,CONTRIB,README,txt/manual.txt}
+ use doc && dohtml -r docs/html/
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/net-analyzer/cacti/files/postinstall-en.txt b/net-analyzer/cacti/files/postinstall-en.txt
new file mode 100644
index 000000000000..732c718005cb
--- /dev/null
+++ b/net-analyzer/cacti/files/postinstall-en.txt
@@ -0,0 +1,62 @@
+
+New Install
+
+1. Create the new cacti database
+ shell> mysqladmin -p --user=root create cacti
+2. Import the default cacti database:
+ shell> mysql -p --user=root cacti < ${MY_INSTALLDIR}/cacti.sql
+3. Create a MySQL username and password for cacti.
+ shell> mysql -p --user=root mysql
+ mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';
+ mysql> flush privileges;
+4. Edit ${MY_INSTALLDIR}/include/config.php and modify the MySQL user,
+ password and database for your cacti configuration.
+
+ Example:
+ \$database_default = "cacti";
+ \$database_hostname = "localhost";
+ \$database_username = "cactiuser";
+ \$database_password = "somepassword";
+
+5. Point your web browser to: http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/
+ Make sure to fill in all of the path variables carefully and
+ correctly on the following screen.
+6. After you've gone through the setup wizard, go back to the main cacti page
+ and login as:
+ Username: admin
+ Password: admin
+
+Upgrading
+
+1. Backup DB in the case that something goes wrong.
+ shell> mysqldump -l --add-drop-table cacti > mysql.cacti
+2. Backup your rra/ directory and any custom scripts in your scripts/
+ directory.
+3. Edit ${MY_INSTALLDIR}/include/config.php, and confirm that the MySQL user,
+ password and database is correct for your cacti configuration.
+
+ Example:
+ \$database_default = "cacti";
+ \$database_hostname = "localhost";
+ \$database_username = "cactiuser";
+ \$database_password = "somepassword";
+4. Point your web browser to: http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/
+ Select "Upgrade".
+ Make sure to fill in all of the path variables carefully and
+ correctly on the following screen.
+
+Cronjob
+
+Either new or upgrading, make sure you have a cron job - Add this line to
+your /etc/crontab file:
+
+ */5 * * * * ${VHOST_SERVER_GID} /usr/bin/php ${MY_INSTALLDIR}/poller.php > /dev/null 2>&1
+
+Note that you should use poller.php as the cronjob instead of cmd.php (as it was with
+earlier versions) to enable you to switch between cmd.php and cactid.
+
+Also make sure that the user poller.php runs as ( ${VHOST_SERVER_GID} ) has
+permission to create new files in Cacti's 'rra/' directory which is
+${MY_INSTALLDIR}/rra
+
+
diff --git a/net-analyzer/cacti/metadata.xml b/net-analyzer/cacti/metadata.xml
new file mode 100644
index 000000000000..dc5780747aad
--- /dev/null
+++ b/net-analyzer/cacti/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription lang="en">
+ Cacti is a complete network graphing solution designed to harness the
+ power of RRDTool's data storage and graphing functionality. Cacti
+ provides a fast poller, advanced graph templating, multiple data
+ acquisition methods, and user management features out of the box. All of
+ this is wrapped in an intuitive, easy to use interface that makes sense
+ for LAN-sized installations up to complex networks with hundreds of
+ devices.
+ </longdescription>
+ <use>
+ <flag name='doc'>install html documentation</flag>
+ </use>
+</pkgmetadata>