summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-09-20 20:33:00 +0200
committerJeroen Roovers <jer@gentoo.org>2016-09-20 20:33:29 +0200
commitcd7ccb340d33dbef1e9c35f28acd093236131c92 (patch)
tree7b086d64800bbe2dc507c8cb056bd770997b0011 /net-analyzer/flowgrind
parentgames-board/gnuchess: 6.2.3, drop games eclass (diff)
downloadgentoo-cd7ccb340d33dbef1e9c35f28acd093236131c92.tar.gz
gentoo-cd7ccb340d33dbef1e9c35f28acd093236131c92.tar.bz2
gentoo-cd7ccb340d33dbef1e9c35f28acd093236131c92.zip
net-analyzer/flowgrind: Version bump.
Package-Manager: portage-2.3.1
Diffstat (limited to 'net-analyzer/flowgrind')
-rw-r--r--net-analyzer/flowgrind/Manifest1
-rw-r--r--net-analyzer/flowgrind/flowgrind-0.8.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/flowgrind/Manifest b/net-analyzer/flowgrind/Manifest
index a203f00fcce0..a3576c1b45b2 100644
--- a/net-analyzer/flowgrind/Manifest
+++ b/net-analyzer/flowgrind/Manifest
@@ -1 +1,2 @@
DIST flowgrind-0.7.1.tar.bz2 224678 SHA256 8356eab1e5acb7c72fad4a92fc0f7d28b20ff014ece4bae2f18e9aac19bdf003 SHA512 fe1bc82d8b1b5bbe37989c0d8f24ba87bca73522983b855e249a3fa5e5fc96d9a63190aa94627db2b1bfea63304e453b4bc1c5fd18260fad9bda38313ad912b8 WHIRLPOOL 691a3125a209b86f33443978f5dce50b39a12425b18116491e56428c60db1ca6ae2f552f005953274895fbe95a42ca66630f93026a0a36d2662bcc2d185ceb39
+DIST flowgrind-0.8.0.tar.bz2 298730 SHA256 2e8b58fc919bb1dae8f79535e21931336355b4831d8b5bf75cf43eacd1921d04 SHA512 2af250da696c4d0f613191e7a2e3084b2aa1dc995665a4164324cdb2cc56af7b000b8a2f5d5e7ac8ebbad3ae0ba4fc8eb641afe65c1a842a633c19e95ba3e65a WHIRLPOOL 29b90336cc34bd6ed12817075203acc3aba8b558f6d58dae7f1390eba4d2ec16d29cb563183eb01164b077a4d20dc8be46c50398e439ca9e0b451c62f5449415
diff --git a/net-analyzer/flowgrind/flowgrind-0.8.0.ebuild b/net-analyzer/flowgrind/flowgrind-0.8.0.ebuild
new file mode 100644
index 000000000000..0353b07855d6
--- /dev/null
+++ b/net-analyzer/flowgrind/flowgrind-0.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Network performance measurement tool"
+HOMEPAGE="http://flowgrind.net/ https://github.com/flowgrind/flowgrind/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc gsl pcap"
+
+RDEPEND="
+ dev-libs/xmlrpc-c[abyss,curl]
+ gsl? ( sci-libs/gsl )
+ pcap? ( net-libs/libpcap )
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with doc doxygen) \
+ $(use_with gsl) \
+ $(use_with pcap)
+}
+
+src_compile() {
+ default
+
+ use doc && emake html
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/html
+}