summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/masscan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/masscan')
-rw-r--r--net-analyzer/masscan/Manifest1
-rw-r--r--net-analyzer/masscan/files/masscan.conf7
-rw-r--r--net-analyzer/masscan/masscan-1.0.3-r1.ebuild44
-rw-r--r--net-analyzer/masscan/metadata.xml23
4 files changed, 75 insertions, 0 deletions
diff --git a/net-analyzer/masscan/Manifest b/net-analyzer/masscan/Manifest
new file mode 100644
index 000000000000..d189e521b15f
--- /dev/null
+++ b/net-analyzer/masscan/Manifest
@@ -0,0 +1 @@
+DIST masscan-1.0.3.tar.gz 333393 SHA256 331edd529df1904bcbcfb43029ced7e2dafe1744841e74cd9fc9f440b8301085 SHA512 e64b11deaaaa71d5be95e8f2b1fdfa679f5c8e8074c97f9d60d57659f33aec0699673c5aab72824f62d1a8b0e8c9188dcf296dd078bc6c2dbdad95c35c3a5f40 WHIRLPOOL fa1c4e931ef0d6ca534b0ccff790e86eef3a058f46b39fff0c94326fa41ddee9007030240a83171171ef10ead862721844330599ff271bbc08ca9f168ff6a3d0
diff --git a/net-analyzer/masscan/files/masscan.conf b/net-analyzer/masscan/files/masscan.conf
new file mode 100644
index 000000000000..86a88868dffe
--- /dev/null
+++ b/net-analyzer/masscan/files/masscan.conf
@@ -0,0 +1,7 @@
+rate = 100000.00
+output-format = xml
+output-status = all
+output-filename = scan.xml
+ports = 0-65535
+#range = 0.0.0.0-255.255.255.255
+excludefile = /etc/masscan/exclude.conf
diff --git a/net-analyzer/masscan/masscan-1.0.3-r1.ebuild b/net-analyzer/masscan/masscan-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..17050b707961
--- /dev/null
+++ b/net-analyzer/masscan/masscan-1.0.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Mass IP port scanner"
+HOMEPAGE="https://github.com/robertdavidgraham/masscan"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="AGPL-3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+src_prepare(){
+ sed -i \
+ -e '/$(CC)/s!$(CFLAGS)!$(LDFLAGS) $(CFLAGS)!g' \
+ -e '/^GITVER :=/s!= .(.*!=!g' \
+ -e '/^SYS/s|gcc|$(CC)|g' \
+ -e '/$(CC)/s!-DGIT=\"$(GITVER)\"!!g' \
+ -e '/^CFLAGS =/{s,=,+=,;s,-g -ggdb,,;s,-O3,,;}' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake CC="$(tc-getCC)" DESTDIR="${D}" PREFIX=/usr install
+
+ insinto /etc/masscan
+ doins data/exclude.conf
+ doins "${FILESDIR}"/masscan.conf
+
+ mv doc/bot.{hml,html} || die
+ dohtml doc/bot.html
+ doman doc/masscan.8
+ dodoc *.md
+}
diff --git a/net-analyzer/masscan/metadata.xml b/net-analyzer/masscan/metadata.xml
new file mode 100644
index 000000000000..dad8fc699840
--- /dev/null
+++ b/net-analyzer/masscan/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ This is the fastest Internet port scanner. It can scan the
+ entire Internet in under 6 minutes, transmitting 10 million
+ packets per second.
+
+ It produces results similar to nmap, the most famous port
+ scanner. Internally, it operates more like scanrand,
+ unicornscan, and ZMap, using asynchronous transmission.
+ The major difference is that it's faster than these other
+ scanners. In addition, it's more flexible, allowing
+ arbitrary address ranges and port ranges.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">robertdavidgraham/masscan</remote-id>
+ </upstream>
+</pkgmetadata>