summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-12-19 13:22:43 +0000
committerMarek Szuba <marecki@gentoo.org>2019-12-19 15:17:09 +0000
commitecb44039cd1074472a7dda4a6d4a61be3ac363c2 (patch)
tree47b19fb5ddc6a9335b833c3c4ed10c0360e997ac /net-analyzer/nessus-bin/nessus-bin-8.8.0.ebuild
parentnet-analyzer/nessus-agent-bin: bump to 7.5.0 (diff)
downloadgentoo-ecb44039cd1074472a7dda4a6d4a61be3ac363c2.tar.gz
gentoo-ecb44039cd1074472a7dda4a6d4a61be3ac363c2.tar.bz2
gentoo-ecb44039cd1074472a7dda4a6d4a61be3ac363c2.zip
net-analyzer/nessus-bin: bump to 8.8.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-analyzer/nessus-bin/nessus-bin-8.8.0.ebuild')
-rw-r--r--net-analyzer/nessus-bin/nessus-bin-8.8.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/nessus-bin/nessus-bin-8.8.0.ebuild b/net-analyzer/nessus-bin/nessus-bin-8.8.0.ebuild
new file mode 100644
index 000000000000..45aa75d3c45a
--- /dev/null
+++ b/net-analyzer/nessus-bin/nessus-bin-8.8.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm pax-utils systemd
+
+MY_P="Nessus-${PV}-es7"
+
+DESCRIPTION="A remote security scanner for Linux"
+HOMEPAGE="https://www.tenable.com/"
+SRC_URI="${MY_P}.x86_64.rpm"
+
+LICENSE="GPL-2 Nessus-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="mirror fetch strip"
+
+QA_PREBUILT="opt/nessus/bin/nasl
+ opt/nessus/bin/ndbg
+ opt/nessus/bin/nessus-mkrand
+ opt/nessus/lib/nessus/libjemalloc.so.2
+ opt/nessus/lib/nessus/libnessus-glibc-fix.so
+ opt/nessus/sbin/nessus-service
+ opt/nessus/sbin/nessuscli
+ opt/nessus/sbin/nessusd"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from ${HOMEPAGE}downloads/nessus"
+ einfo "The archive should then be placed into your DISTDIR directory."
+}
+
+src_install() {
+ # Using doins -r would strip executable bits from all binaries
+ cp -pPR "${S}"/opt "${D}"/ || die "Failed to copy files"
+
+ pax-mark m "${D}"/opt/nessus/sbin/nessusd
+
+ # Make sure these originally empty directories do not vanish,
+ # Nessus will not run properly without them
+ keepdir /opt/nessus/com/nessus/CA
+ keepdir /opt/nessus/etc/nessus
+ keepdir /opt/nessus/var/nessus/logs
+ keepdir /opt/nessus/var/nessus/tmp
+
+ newinitd "${FILESDIR}"/nessusd-initd nessusd-bin
+ systemd_newunit usr/lib/systemd/system/nessusd.service nessusd-bin.service
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To get started launch the nessusd-bin service, then point your Web browser to"
+ elog " https://<yourhost>:8834/"
+ else
+ elog "You may want to restart the nessusd-bin service to use"
+ elog "the new version of Nessus."
+ fi
+}