summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-02-22 12:04:21 +0100
committerSam James <sam@gentoo.org>2021-03-15 23:25:10 +0000
commit8c4cdd5880de5f8ea6c65e360cfb21537fa14cf4 (patch)
tree083afe66100c640d833c194d940574f332d7ad7d /net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild
parentnet-analyzer/nbwmon: EAPI7 bump (diff)
downloadgentoo-8c4cdd5880de5f8ea6c65e360cfb21537fa14cf4.tar.gz
gentoo-8c4cdd5880de5f8ea6c65e360cfb21537fa14cf4.tar.bz2
gentoo-8c4cdd5880de5f8ea6c65e360cfb21537fa14cf4.zip
net-analyzer/nethogs: added capabilities
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19587 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild')
-rw-r--r--net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild b/net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild
new file mode 100644
index 000000000000..4cf2b0092cbe
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps toolchain-funcs
+
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+HOMEPAGE="https://github.com/raboof/nethogs"
+SRC_URI="https://github.com/raboof/nethogs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86"
+DOCS=( DESIGN README.decpcap.txt README.md )
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC CXX
+ emake NCURSES_LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )" "${PN}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="/usr" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ ecaps cap_net_admin,cap_net_raw "${EROOT}/usr/bin/nethogs"
+}