summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-15 23:30:38 +0000
committerSam James <sam@gentoo.org>2021-03-15 23:30:38 +0000
commit6db0315d786c499a9526ce7ee71d3229fea8fd26 (patch)
treee5a552fcbc0fd84e0ae1d61b6f5ca03324f57208 /net-analyzer/nethogs
parentnet-analyzer/nethogs: keep stable keywords for 0.8.6-r1 (diff)
downloadgentoo-6db0315d786c499a9526ce7ee71d3229fea8fd26.tar.gz
gentoo-6db0315d786c499a9526ce7ee71d3229fea8fd26.tar.bz2
gentoo-6db0315d786c499a9526ce7ee71d3229fea8fd26.zip
net-analyzer/nethogs: fix adding capabilities
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/nethogs')
-rw-r--r--net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild b/net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild
index 16a6a36ff847..e0f115871a58 100644
--- a/net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild
+++ b/net-analyzer/nethogs/nethogs-0.8.6-r1.ebuild
@@ -24,6 +24,10 @@ BDEPEND="
virtual/pkgconfig
"
+FILECAPS=(
+ cap_net_admin,cap_net_raw usr/sbin/nethogs
+)
+
src_compile() {
tc-export CC CXX
emake NCURSES_LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )" "${PN}"
@@ -33,7 +37,3 @@ src_install() {
emake DESTDIR="${ED}" PREFIX="/usr" install
einstalldocs
}
-
-pkg_postinst() {
- ecaps cap_net_admin,cap_net_raw "${EROOT}/usr/bin/nethogs"
-}