summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-08-21 12:54:48 -0400
committerRick Farina <zerochaos@gentoo.org>2023-08-21 13:07:12 -0400
commitab1e58d84d22776c5546da327e2e729aaa518eac (patch)
treecf406f12ad5935ba65cbc5503d19f0f3693fe7d6 /net-analyzer/ostinato
parentnet-proxy/haproxy: Cleanup old confd (diff)
downloadgentoo-ab1e58d84d22776c5546da327e2e729aaa518eac.tar.gz
gentoo-ab1e58d84d22776c5546da327e2e729aaa518eac.tar.bz2
gentoo-ab1e58d84d22776c5546da327e2e729aaa518eac.zip
net-analyzer/ostinato: add 1.2.0
Additionally rename drone to ostinato-drone Bug: https://bugs.gentoo.org/show_bug.cgi?id=912264 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-analyzer/ostinato')
-rw-r--r--net-analyzer/ostinato/Manifest1
-rw-r--r--net-analyzer/ostinato/ostinato-1.2.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/ostinato/Manifest b/net-analyzer/ostinato/Manifest
index 563c348f41f4..781d32d58930 100644
--- a/net-analyzer/ostinato/Manifest
+++ b/net-analyzer/ostinato/Manifest
@@ -1 +1,2 @@
DIST ostinato-1.1.tar.gz 612589 BLAKE2B 2244b3be5649e0623139b667c61a169a3e7f5dae6f022d6550cd825f1af8fa2c2d82210af1f381ae53af19fff9a56d58b30a406fc1f3d89c73bc7e3d0ab18fa4 SHA512 a45e157d155d4f2efe9a1594a140647b5cbd7264985b15a9ed47d86198c9df9d763170097dcfd40fae1317206e53c9155f08c48c747cce458e0cae7f3a841449
+DIST ostinato-1.2.0.tar.gz 1169889 BLAKE2B 73d1ba4801ee8f50757fbe3a5e4c6fb67957296326c5ffcc5ecfde723ee975bd6a8f494644198b4b47a296fd087e2ed7a43088facd8c39d3ed70b8056fae5da5 SHA512 c3fb1f63a8f32c199ae2c8630244a3d6110e25e9117fbc96b009fd54d6bc16dbfa120b2d26c474ca06e86dbed59a5051443f82064fb8a0eda2feb212e4e1a1c5
diff --git a/net-analyzer/ostinato/ostinato-1.2.0.ebuild b/net-analyzer/ostinato/ostinato-1.2.0.ebuild
new file mode 100644
index 000000000000..9c346092d15c
--- /dev/null
+++ b/net-analyzer/ostinato/ostinato-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Packet generator and analyzer"
+HOMEPAGE="https://ostinato.org/"
+SRC_URI="https://github.com/pstavirs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#https://github.com/pstavirs/ostinato/issues/173
+# libpcap dep is versioned to pull in the fix for #602098
+RDEPEND="
+ dev-libs/protobuf:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtwidgets:5
+ dev-libs/libnl:3
+ >=net-libs/libpcap-1.8.1-r2
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtxml:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9_p20180522-no-modeltest.patch"
+)
+
+src_configure() {
+ sed -i 's#"/drone"#"/ostinato-drone"#' client/mainwindow.cpp || die
+ eqmake5 PREFIX="/usr" ost.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+ mv "${ED}"/usr/bin/{drone,ostinato-drone}
+}