summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-03 10:23:17 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-03 10:23:38 +0200
commitfac63b866dff9c88a264bd752c5e702256411927 (patch)
tree6209147390d2711d768e4cd6986e0742cbda8e79 /net-analyzer/tcptraceroute
parentnet-analyzer/softflowd: Version 1.0.0 (diff)
downloadgentoo-fac63b866dff9c88a264bd752c5e702256411927.tar.gz
gentoo-fac63b866dff9c88a264bd752c5e702256411927.tar.bz2
gentoo-fac63b866dff9c88a264bd752c5e702256411927.zip
net-analyzer/tcptraceroute: Update SRC_URI/EAPI
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/tcptraceroute')
-rw-r--r--net-analyzer/tcptraceroute/tcptraceroute-1.5_beta7-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/tcptraceroute/tcptraceroute-1.5_beta7-r3.ebuild b/net-analyzer/tcptraceroute/tcptraceroute-1.5_beta7-r3.ebuild
new file mode 100644
index 000000000000..1479b57dfa88
--- /dev/null
+++ b/net-analyzer/tcptraceroute/tcptraceroute-1.5_beta7-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="tcptraceroute is a traceroute implementation using TCP packets"
+HOMEPAGE="https://github.com/mct/tcptraceroute"
+SRC_URI="https://github.com/mct/${PN}/archive/${P/_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ net-libs/libnet:1.1
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}"/${P}-cross-compile-checks.patch
+)
+S=${WORKDIR}/${PN}-${P/_}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dosbin tcptraceroute
+ fowners root:wheel /usr/sbin/tcptraceroute
+ fperms 4710 /usr/sbin/tcptraceroute
+ doman tcptraceroute.1
+ dodoc examples.txt README ChangeLog
+ docinto html
+ dodoc tcptraceroute.1.html
+}