summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 01:39:56 +0100
committerSam James <sam@gentoo.org>2021-04-03 17:10:30 +0100
commitceff568ec25f068bd4c5aedd66e1c1c905d0804f (patch)
treeb4caddd849bc5da6bbb1498b0616cf5741cba232 /net-analyzer/thc-ipv6
parentnet-analyzer/tcpreplay: EAPI 7, flag-o-matic-- (diff)
downloadgentoo-ceff568ec25f068bd4c5aedd66e1c1c905d0804f.tar.gz
gentoo-ceff568ec25f068bd4c5aedd66e1c1c905d0804f.tar.bz2
gentoo-ceff568ec25f068bd4c5aedd66e1c1c905d0804f.zip
net-analyzer/thc-ipv6: EAPI 7, consistent style, misc QA
* Port to EAPI 7 * Drop unused eutils * Missing || die * Use standard ebuild "block structure" * Sort DEPEND * Use consistent semicolon style Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/thc-ipv6')
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-3.2-r1.ebuild42
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild42
2 files changed, 48 insertions, 36 deletions
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-3.2-r1.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-3.2-r1.ebuild
index 71f98da3f733..396a0b2a2160 100644
--- a/net-analyzer/thc-ipv6/thc-ipv6-3.2-r1.ebuild
+++ b/net-analyzer/thc-ipv6/thc-ipv6-3.2-r1.ebuild
@@ -1,46 +1,52 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-ipv6.git"
-EGIT_BRANCH=master
+EAPI=7
-inherit eutils toolchain-funcs ${SCM}
+inherit toolchain-funcs
-DESCRIPTION="complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
+DESCRIPTION="Complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
HOMEPAGE="https://www.thc.org/thc-ipv6/"
-LICENSE="AGPL-3 openssl"
-SLOT="0"
-IUSE="ssl"
-if [[ ${PV} != *9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-ipv6.git"
+ EGIT_BRANCH=master
+ inherit git-r3
+else
SRC_URI="https://github.com/vanhauser-thc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
-DEPEND="net-libs/libpcap
+LICENSE="AGPL-3 openssl"
+SLOT="0"
+IUSE="ssl"
+
+DEPEND="
net-libs/libnetfilter_queue
- ssl? ( dev-libs/openssl:0= )"
+ net-libs/libpcap
+ ssl? ( dev-libs/openssl:0= )
+"
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${PN}-3.2-stdint.patch" )
src_unpack() {
- if [[ ${PV} != *9999 ]]; then
- default_src_unpack
- else
+ if [[ ${PV} == *9999 ]]; then
git-r3_src_unpack
fi
+
+ default
}
src_prepare() {
sed -e '/^CFLAGS=/s,CFLAGS=,CFLAGS?=,' \
-i Makefile || die
- if ! use ssl ; then
+
+ if ! use ssl; then
sed -e '/^HAVE_SSL/s:^:#:' \
- -i Makefile
+ -i Makefile || die
fi
+
default
}
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
index 71f98da3f733..396a0b2a2160 100644
--- a/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
+++ b/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
@@ -1,46 +1,52 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-ipv6.git"
-EGIT_BRANCH=master
+EAPI=7
-inherit eutils toolchain-funcs ${SCM}
+inherit toolchain-funcs
-DESCRIPTION="complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
+DESCRIPTION="Complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
HOMEPAGE="https://www.thc.org/thc-ipv6/"
-LICENSE="AGPL-3 openssl"
-SLOT="0"
-IUSE="ssl"
-if [[ ${PV} != *9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-ipv6.git"
+ EGIT_BRANCH=master
+ inherit git-r3
+else
SRC_URI="https://github.com/vanhauser-thc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
-DEPEND="net-libs/libpcap
+LICENSE="AGPL-3 openssl"
+SLOT="0"
+IUSE="ssl"
+
+DEPEND="
net-libs/libnetfilter_queue
- ssl? ( dev-libs/openssl:0= )"
+ net-libs/libpcap
+ ssl? ( dev-libs/openssl:0= )
+"
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${PN}-3.2-stdint.patch" )
src_unpack() {
- if [[ ${PV} != *9999 ]]; then
- default_src_unpack
- else
+ if [[ ${PV} == *9999 ]]; then
git-r3_src_unpack
fi
+
+ default
}
src_prepare() {
sed -e '/^CFLAGS=/s,CFLAGS=,CFLAGS?=,' \
-i Makefile || die
- if ! use ssl ; then
+
+ if ! use ssl; then
sed -e '/^HAVE_SSL/s:^:#:' \
- -i Makefile
+ -i Makefile || die
fi
+
default
}