summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-05-13 11:59:13 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-05-13 11:59:48 +0800
commit267be547af3433faf9d414a1db345b89b51fcffd (patch)
treea3234e126ec7b5b7a4177f1a187f59e246ff7fe2 /net-analyzer
parentdev-util/nvidia-cuda-toolkit: allow gcc-8.4 for cuda-10.{1,2}. (diff)
downloadgentoo-267be547af3433faf9d414a1db345b89b51fcffd.tar.gz
gentoo-267be547af3433faf9d414a1db345b89b51fcffd.tar.bz2
gentoo-267be547af3433faf9d414a1db345b89b51fcffd.zip
net-analyzer/openbsd-netcat: version bump.
1.195 is in Debian stable. Suggested-By: <doj@cubic.org> Bug: https://bugs.gentoo.org/680224 Package-Manager: Portage-2.3.88, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/openbsd-netcat/Manifest2
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.195.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/openbsd-netcat/Manifest b/net-analyzer/openbsd-netcat/Manifest
index 6b9fe794d87a..0ccf2ff4923b 100644
--- a/net-analyzer/openbsd-netcat/Manifest
+++ b/net-analyzer/openbsd-netcat/Manifest
@@ -2,3 +2,5 @@ DIST netcat-openbsd_1.105-7.debian.tar.gz 31843 BLAKE2B 115eb2d0c0f35055eb266087
DIST netcat-openbsd_1.105.orig.tar.gz 14891 BLAKE2B 65119a4e2cb3d9cd7b2d7d346b827ff1c175cc3255f40d70bbd45213b438635d6b063b3cf210d27595e38b0d67339788221ae5c3737e6096782245fb573bca3a SHA512 1e515b5af83a12c6f270d6e8bede6406cc7c9f83ca0e316816508dfe2e2c49cda3fffb6b24a3922bf9908dc8b70d540eb8cc49e9cbfe867e49133c004d3f4703
DIST netcat-openbsd_1.190-2.debian.tar.xz 34836 BLAKE2B 3ff4390c07d05e8d1a19c8696da12bdc6bba07c6e88281b04cd7915509f44a14dda66462128da768b255d92f3a02d008750a860db9290f9f8e0e0bb9dd66e01b SHA512 c33510ad6761627e0b7e564747f6ae82c7569157bdc91f6a282a97b038b2b0917c27fdfba137462c7c34d84fcfdfe8b6393204884d153e3d200a86f5c6657a9a
DIST netcat-openbsd_1.190.orig.tar.gz 22384 BLAKE2B c3e83106f53a0214f71c805b1dfe6b66718dfca217f713a0d7016cb0a3c75c78580fbdd277bd7b5324371145c4b986ebb867e6f779cd61ffecb8e732ebabcb84 SHA512 32310813391f63b8283dc4a63e52821e464ecbfcd0ea995e8e15047c6252a86b31eb4725dc69b778594c43d6ce0cc081aa0f00d7cda0587c91941f20b93a33fe
+DIST netcat-openbsd_1.195-2.debian.tar.xz 35984 BLAKE2B eedac24eedc243ad1d58576be76f4f98392e1f455863fa3cdc06bde2714612819b7dfa98dd45c1739a65680469460410f5e4b2f4144f4c24fea04b59dda4d0da SHA512 2a5cc6d04112fdde007be4b9adb3aee44060570c0cb2ae0e33e54af3d37c0b2ff4d6c96edf1f16047365106c7c3720195b38417af3c332226c9be81d49caa552
+DIST netcat-openbsd_1.195.orig.tar.gz 22480 BLAKE2B 53c750c168d7ea5dc2ca653598e42700e2b3ee888d946a09503a22fa3bcbc2c73658f38787314bef628d609ad370223f6889b7019760bf51817f73fc570e1dcc SHA512 ea95cda028f2759835ea8832db0174c178b002d5a917f4c51594445a5377a30d6114ac261071eea98d3d0b60ae1ec72102609db1625dbc5a6e57c67e28d2ff51
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.195.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.195.ebuild
new file mode 100644
index 000000000000..363c5e7a8193
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.195.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="The OpenBSD network swiss army knife"
+HOMEPAGE="https://cvsweb.openbsd.org/src/usr.bin/nc/
+ https://salsa.debian.org/debian/netcat-openbsd"
+SRC_URI="http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz
+ http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}-2.debian.tar.xz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="elibc_Darwin"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x64-macos"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="!elibc_Darwin? ( dev-libs/libbsd )
+ !net-analyzer/netcat
+ !net-analyzer/netcat6
+"
+
+S=${WORKDIR}/netcat-openbsd-${PV}
+
+src_prepare() {
+ for i_patch in $(<"${WORKDIR}"/debian/patches/series); do
+ eapply "${WORKDIR}"/debian/patches/"${i_patch}"
+ done
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # this undoes some of the Debian/Linux changes
+ eapply "${FILESDIR}"/${P}-darwin.patch
+ fi
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin nc
+ doman nc.1
+ cd "${WORKDIR}"/debian || die
+ newdoc netcat-openbsd.README.Debian README
+ dodoc -r examples
+}
+
+pkg_postinst() {
+ if [[ ${KERNEL} = "linux" ]]; then
+ ewarn "SO_REUSEPORT is introduced in linux 3.9. If your running kernel is older"
+ ewarn "and kernel header is newer, nc will not listen correctly. Matching the header"
+ ewarn "to the running kernel will do. See bug #490246 for details."
+ fi
+}