summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2024-11-14 11:15:54 +0100
committerSam James <sam@gentoo.org>2024-11-21 16:29:30 +0000
commit41f61feb9079087f50f03353d5f8a28907f1c4d9 (patch)
tree05816eda1a0827bd0f2e70ad49909bc7764c0933 /net-analyzer
parentdev-libs/xmlrpc-c: Package xmlrpc-c 1.59.03 (diff)
downloadgentoo-41f61feb9079087f50f03353d5f8a28907f1c4d9.tar.gz
gentoo-41f61feb9079087f50f03353d5f8a28907f1c4d9.tar.bz2
gentoo-41f61feb9079087f50f03353d5f8a28907f1c4d9.zip
net-analyzer/netdata: Add an upstream patch to fix building with clang-19
Clang has a new warning (-Wmissing-template-arg-list-after-template-kw) that requires a template argument list after using the template keyword. The upstream dlib (transcluded into netdata by the means of git submodules) has fixed this issue, but netdata has not yet picked up this change. Instead, apply the change directly to the vendored dlib for all versions affected by this. Signed-off-by: Andrej Shadura <andrew.shadura@collabora.co.uk> Closes: https://github.com/gentoo/gentoo/pull/39315 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netdata/files/netdata-dlib-global_optimization-add-template-argument-list.patch30
-rw-r--r--net-analyzer/netdata/netdata-1.45.4.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-1.46.1.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-1.46.2.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-1.46.3.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-1.47.0.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-1.47.1.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-1.47.2.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-1.47.4.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-1.47.5.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild4
11 files changed, 70 insertions, 0 deletions
diff --git a/net-analyzer/netdata/files/netdata-dlib-global_optimization-add-template-argument-list.patch b/net-analyzer/netdata/files/netdata-dlib-global_optimization-add-template-argument-list.patch
new file mode 100644
index 000000000000..43aba15f4980
--- /dev/null
+++ b/net-analyzer/netdata/files/netdata-dlib-global_optimization-add-template-argument-list.patch
@@ -0,0 +1,30 @@
+From 0947215ddb268fef192e45c140c9430f77648166 Mon Sep 17 00:00:00 2001
+From: Drew Risinger <10198051+drewrisinger@users.noreply.github.com>
+Date: Tue, 25 Jun 2024 19:01:12 -0700
+Subject: [PATCH] global_optimization: add template argument list (#2973)
+
+Fixes error (-Wmissing-template-arg-list-after-template-kw) from clang-19 compiler.
+
+Co-authored-by: Drew Risinger <drewrisinger@users.noreply.github.com>
+
+Origin: upstream, https://github.com/davisking/dlib/pull/2973
+---
+ src/ml/dlib/dlib/global_optimization/find_max_global.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/ml/dlib/dlib/global_optimization/find_max_global.h b/src/ml/dlib/dlib/global_optimization/find_max_global.h
+index 12e496e69894..8a05ae9050d4 100644
+--- a/src/ml/dlib/dlib/global_optimization/find_max_global.h
++++ b/src/ml/dlib/dlib/global_optimization/find_max_global.h
+@@ -58,7 +58,7 @@ namespace dlib
+ }
+
+ template <typename T>
+- static auto go(T&& f, const matrix<double,0,1>& a) -> decltype(call_function_and_expand_args<max_unpack-1>::template go(std::forward<T>(f),a))
++ static auto go(T&& f, const matrix<double,0,1>& a) -> decltype(call_function_and_expand_args<max_unpack-1>::template go<T>(std::forward<T>(f),a))
+ {
+ return call_function_and_expand_args<max_unpack-1>::go(std::forward<T>(f),a);
+ }
+--
+2.43.0
+
diff --git a/net-analyzer/netdata/netdata-1.45.4.ebuild b/net-analyzer/netdata/netdata-1.45.4.ebuild
index 725670699e12..4cc5eeff63bd 100644
--- a/net-analyzer/netdata/netdata-1.45.4.ebuild
+++ b/net-analyzer/netdata/netdata-1.45.4.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
# -Werror=strict-aliasing
# https://bugs.gentoo.org/927174
diff --git a/net-analyzer/netdata/netdata-1.46.1.ebuild b/net-analyzer/netdata/netdata-1.46.1.ebuild
index 2f9af0d43617..31f88a05f8fd 100644
--- a/net-analyzer/netdata/netdata-1.46.1.ebuild
+++ b/net-analyzer/netdata/netdata-1.46.1.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
diff --git a/net-analyzer/netdata/netdata-1.46.2.ebuild b/net-analyzer/netdata/netdata-1.46.2.ebuild
index 2f9af0d43617..31f88a05f8fd 100644
--- a/net-analyzer/netdata/netdata-1.46.2.ebuild
+++ b/net-analyzer/netdata/netdata-1.46.2.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
diff --git a/net-analyzer/netdata/netdata-1.46.3.ebuild b/net-analyzer/netdata/netdata-1.46.3.ebuild
index 2f9af0d43617..31f88a05f8fd 100644
--- a/net-analyzer/netdata/netdata-1.46.3.ebuild
+++ b/net-analyzer/netdata/netdata-1.46.3.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
diff --git a/net-analyzer/netdata/netdata-1.47.0.ebuild b/net-analyzer/netdata/netdata-1.47.0.ebuild
index 2f9af0d43617..31f88a05f8fd 100644
--- a/net-analyzer/netdata/netdata-1.47.0.ebuild
+++ b/net-analyzer/netdata/netdata-1.47.0.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
diff --git a/net-analyzer/netdata/netdata-1.47.1.ebuild b/net-analyzer/netdata/netdata-1.47.1.ebuild
index 2f9af0d43617..31f88a05f8fd 100644
--- a/net-analyzer/netdata/netdata-1.47.1.ebuild
+++ b/net-analyzer/netdata/netdata-1.47.1.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
diff --git a/net-analyzer/netdata/netdata-1.47.2.ebuild b/net-analyzer/netdata/netdata-1.47.2.ebuild
index 2f9af0d43617..31f88a05f8fd 100644
--- a/net-analyzer/netdata/netdata-1.47.2.ebuild
+++ b/net-analyzer/netdata/netdata-1.47.2.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
diff --git a/net-analyzer/netdata/netdata-1.47.4.ebuild b/net-analyzer/netdata/netdata-1.47.4.ebuild
index 2f9af0d43617..31f88a05f8fd 100644
--- a/net-analyzer/netdata/netdata-1.47.4.ebuild
+++ b/net-analyzer/netdata/netdata-1.47.4.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
diff --git a/net-analyzer/netdata/netdata-1.47.5.ebuild b/net-analyzer/netdata/netdata-1.47.5.ebuild
index 2f9af0d43617..31f88a05f8fd 100644
--- a/net-analyzer/netdata/netdata-1.47.5.ebuild
+++ b/net-analyzer/netdata/netdata-1.47.5.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 2f9af0d43617..31f88a05f8fd 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -94,6 +94,10 @@ pkg_setup() {
linux-info_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-dlib-global_optimization-add-template-argument-list.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Git=TRUE